1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

[BNW] Visuals and user interface broken/corrupted graphics?

Discussion in 'Civ5 - Technical Support' started by Gandorhad, May 19, 2017.

  1. Gandorhad

    Gandorhad Chieftain

    Joined:
    Aug 16, 2016
    Messages:
    7
    Location:
    Pirot, Serbia

    So, here are two pictures of my civ 5 bnw. This happened after I tried to install some mods through steam, I usually download them manually since its more reliable and when I started, I had about 70 mods prior to adding these few new ones, this glitch or bug, dont know how to name it happened. First it only affected matches with mods, so I went mod by mod, to determine the fault one, but didnt find one...
    Then it started affecting my single player regular games, I tried reinstalling, checking for file integrity through steam etc..
    Nothing seemed to help.
    I cant play with any mods, if I do, even my SP gets wrecked again :S
    Currently I can only play without mods, and every other time or so, I get the glitchy screen again and have to restart my laptop. But the problem is there.
    Is there something that can be done to help me, or do I go to pirate bay and fix the problem that way?
    p.s. It affects some games on MP too, sometimes...
    usually it happens on start up, or if Im unlucky on resyncs.
    p.p.s. These images were nothing, usually I get a sea of corrupted graphics and its realy frustrating. The game from the images is usual SP, no mods, it was playable, but not enjoyable at all!!!
     

Share This Page