1.17 patch

bholed

King
Joined
Feb 21, 2002
Messages
860
Location
Edinburgh
Having problems downloading the patch ?

Message-
" The contents of this file cannot be unpacked, The executable you are attempting to run has been corrupted.
Please obtain another copy , verify its integrity and try again"??

Has this happened to anyone else? and does anyone have any
tips.

Cheers
..
 
I often have trouble downloading from this site, sometimes from others. I guess it`s my Netscape 6.2/WinXP home combination. Try the offical CivIII site from Firaxis; might work there!
 
Top Bottom