• Civilization 7 has been announced. For more info please check the forum here .

Crashes on AI's turn


Mar 5, 2010
[GS] []

The attached game will crash on Dido's turn if you take next turn. Nothing I did on the turn mattered; I include the autosave from the beginning of the turn to prove that.

In the past, when it has crashed on an AI's turn, I use multiplayer HotSeat to investigate. In this case, I changed Dido from AI to Human. For some reason, I couldn't start from this end of turn, but I could from the beginning of turn, making the same moves, for the Incas. When the game got to Dido's turn, one city needed to set production, after losing Potala's Palace.

I don't know what the AI decided to build. I set production to finish the walls, saved that so I could change Dido back to AI, and continued from there.

On Dido's next AI turn, it crashed again. I repeated the above process. Biruta finished the walls, with the excess from losing Potala's Palace, and I set production to University and continued in single player. Next turn was fine.

Note, since I play at Diety, when setting Dido to Human, Dido doesn't get all the production it would get normally. So maybe it's a production overflow issue. I'm not able to investigate further.

Could some Windows user confirm that the first attached saved game crashes for you, and then report it to Firaxis? They won't listen to me because I play on a Mac, and can't give them the crash files they want, even if I give them a save game that will crash for them. They tell me to report it to Aspyr, ignoring the fact that if it crashes for Windows users, it's not Aspyr's problem.



  • Inca 138 begin.Civ6Save
    2 MB · Views: 32
  • PACHACUTI 138 540 AD end turn.Civ6Save
    2 MB · Views: 27
  • Inca 138 begin.Civ6Save
    2 MB · Views: 28
  • DIDO 138 540 AD.Civ6Save
    1.9 MB · Views: 21
When the University finished, it crashed again (on Dido's turn). So apparently I merely delayed Dido choosing to build something that causes the game to crash. I suspected it was trying to build a district. So I went back to the HotSeat file for the start of Dido's turn 138 (4th file uploaded above).

I tried aqueducts both NW and SE of Biruta. Both worked. (The AI likes aqueducts too much.)
While a commercial hub might have made sense, both of the one's Dido had were captured from Mali. But I noticed they liked to build encampments. So I tried encampments in the three possible locations west of Biruta -- all three cause clearing. Two worked.

Trying to build an encampment on the NW jungle tile (2F, 2P) next to the mountain immediately causes the game to crash. It also immediately crashes if one tries to build a commercial hub there, or an industrial zone, so presumably any (legitimate) district. However, starting Chitzen Itza there doesn't cause a crash, so the problem may be related to clearing that jungle.


Unfortunately, this cripples this game for me. Dido is always going to try to build a district there when it gets a chance, so I have to set production for Biruta to something else ... forever. I wouldn't care if Dido was not competitive, but it's currently the leader in both score and tech.

Again, could some Windows user confirm that it crashes this way for them, and submit it to Firaxis? (Note that you have to load Dido 138 540 AD in HotSeat) Thanks.
Top Bottom