1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

DX11/DX12 Update graphics driver crash

Discussion in 'Civ6 - Technical Support' started by Keebs, May 13, 2019.

  1. Keebs

    Keebs Chieftain

    Joined:
    May 13, 2019
    Messages:
    1
    Hello.
    I am a long time civ player in general running Windows 10, version 1803.

    Latest steam update for civ, and I have all DLC for Civ VI. Including gathering storm.

    For the past 3 months (ever since release of gathering storm) I can't play more than 20-30 turns without crashing. All it says is to make sure I have most up to date graphics drivers and this happens on DX11 and DX12. I have tried every fix imaginable besides reinstalling windows directly.
    • Verifying game integrity always gives me 3 files that failed to validate and will be reacquired.
    • I have tried with mods, without mods, everything.
    • Reinstalling my GPU drivers clean.
    • Completely removing GPU drivers, rebooting, removing left over files, rebooting again, then installing.
    • Launching steam as administrator and again reinstalling game after still crashing.
    • Reinstalling game, deleting my game folder in documents and in steam/common/.
    • Turning graphics settings up and down (including disabling anti-aliasing, vsync off and on)
    • Starting in DX11 instead of DX12 (and vise versa)

    Everything leads to the same crash of driver failure and either update driver, or make sure they are up to date. No other game in my library of 200 crashes because of drivers so I really doubt its the drivers fault.


    I took a long break from the game but I bought 2 copies of all DLC and game for me and wife to play and its so frustrating getting into a good rhythm just to crash 10-15 minutes later and I have buddies who wanna play. When I rejoin the game I get a loading screen every turn and crash in another few turns.


    I have a 8700k i7, 1070 Nvidia GPU, 16gb ram, SSD it was installed on. I have also tried installing it on different drives to no avail too. I put a ticket in with 2k last week but I have no response on it yet so I am not even sure its going to lead anywhere. I have found 7-8 other threads on reddit/2k forums about this same problem and plenty of comments having the same issue.

    Any help would be amazing, I appreciate everyone who spends time on here trying to troubleshoot with other users.
     

    Attached Files:

Share This Page