1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

i getting a little upset

Discussion in 'Civ4 - Technical Support' started by harlowheat, Oct 28, 2005.

  1. harlowheat

    harlowheat Chieftain

    Joined:
    Oct 11, 2005
    Messages:
    19
    :cry: someone please help me
    i bought the game yesterdayloaded the game fine went to play and the only thing i seen was the units and resources
    then i came to civfanatics and someone said to play a little while and it begins to clears it self.
    it did and the more times i played different single games it came clearer and more faster .
    i had to go to work and just now came to play and now the loading screen and all of a sudden nothing, i can hear it but cant see it just my desktop
    i have a AMD Athlon 3000+ processor
    160 gig's
    NVIDIA Geforce 4 MX
    512 ddr sdram
    preety awesome computer in my standards and i really want to play this game
    someone please help
     

Share This Page