1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

MODs compatible with Community Balance Patch (CBP)

Discussion in 'Community Patch Project' started by vyyt, Jan 29, 2015.

  1. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Mods compatible with the Vox Populi (VP)

    This thread is meant to track compatibility of mods you might want to try in combination with the standard Community Balance Patch (VP). The mods are divided into following categories, each category is in its own post:

    • Compatible "out of the box"
    • Incorporated into VP
    • Compatible after tweaking some files / need special VP version
    • Not compatible


    Important notice:

    1. VP is still under development, which means the compatibility might change in time. If you find a mod in a wrong category, please write a comment and I will update the list.
    2. Mods in CiV are strange beasts. Sometimes a mod seems to be incompatible for 1 player, but works fine for another (usually clearing the Cache and ModUserData folders helps, sometimes not).
    3. If you intend to use only CP (the core which improves AI and fixes bugs - no balance/rules changes), most mods should not conflict, however you cannot use CP together with any other mod using DLL

    Therefore please do not take this list for 100% guaranteed.


    Please contribute / help to update this list:

    If you have tested a new mod with VP, please write a new comment (preferrable) or PM me (also fine, but I might overlook it) and include the mod name, state if it was or was not compatible and a download link will be nice too. I will update the list accordingly. If the mod is only partially compatible and some files need to be edited in order to make it work, please include instructions in your post or start a new thread and I will link it from here.
     
    Last edited: Feb 1, 2018
    Hillclimber likes this.
  2. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Compatible "out of the box"

    The mods below should be compatible with the standard VP setup right away. In addition to the mods below the vast majority of WHoward's Pick'N'Mix Mods should be compatible too unless the mod is already incorporated in VP or conflicts with something in it (which is very rare) - I list the incorporated ones and incompatible ones in the following posts above.


    Sets/packages of multiple MOD groups from same author with their own thread / website:


    List of separate MODs:
     
    Last edited: Aug 30, 2018
  3. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Incorporated into VP

    These mods are part of VP - you do not need to download them separately. Actually you should not, as they might cause the game to crash. If you do have a stand-alone version of any of these mods, I recommend to remove it from your MODs folder (and unsubscribe if you added it on Steam Workshop) as it might conflict with its VP version counterpart even it is not activated.

    Important: the links are included only to provide more information about the mods if you are not familiar with them, you are not supposed to use the links to download the mods - they are already incorporated in VP


     
    Last edited: Feb 20, 2018
  4. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Compatible after tweaking some files / need special VP version

    Following mods work only partially with VP or only after altering some files either within VP or within the said mod - see the mod descriptions.

     
    Last edited: Feb 5, 2018
  5. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Mods not compatible with VP

    Important: In addition to the mods listed below, any mod which contains DLL will not work with VP.

     
    Last edited: Aug 30, 2018
  6. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Are you playing CBP in combination with a mod not listed below? Did you try a mod in combination with CBP and it caused a crash or some strange glitches?

    Then please leave a comment (preferrable) or PM me (I might overlook it) and I will add the mod to the lists below.

    Please include the mod name, state if it was or was not compatible and a download link will be nice too.
     
  7. Funak

    Funak Chieftain

    Joined:
    Jul 15, 2013
    Messages:
    9,127
  8. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Thanks. Yeah, if I remember correctly, that's what JFD said in another thread. I just hope all of the civs in the pack are compatible, so that we do not have to list them one by one :lol:

    They look very nice, I will try some of them next time I play.
     
  9. Funak

    Funak Chieftain

    Joined:
    Jul 15, 2013
    Messages:
    9,127
    There were some things that were more or less optimal for the CPP style of play. All I did was report issues I could see in the civpedia. There are probably other things that needs ironing out, but the only way to find them is to have people try them out.

    In other words they should work, but I'm not 100% sure that everything is balanced perfectly.
     
  10. WileyNg

    WileyNg Chieftain

    Joined:
    Aug 17, 2013
    Messages:
    595
    Location:
    Hong Kong
    And JFD's cultural diversity.
    But can you group all of whoward's mod into one group?
    just some simple formatting because many of his mods are quite similar in nature and they all are compatible for sure. No need to state the obvious. In fact I think we should remove Whoward's minimod from the list and instead put a link to direct to his website which is already very neat and well-organized already.

    It is the "big" and popular mod that should be on the list, like JFD's civilization, his Cultural diversity, InfoAddict, RED Mod pack, YnAEMP...etcetc
     
  11. WileyNg

    WileyNg Chieftain

    Joined:
    Aug 17, 2013
    Messages:
    595
    Location:
    Hong Kong
    And you missed out Civ 4 Diplomacy Features in the mods that are incorporated in CBP
     
  12. Anastase Alex

    Anastase Alex Chieftain

    Joined:
    Jul 10, 2013
    Messages:
    217
    Location:
    Paris
    From whowards no more civilian trafic jams is amazing.
     
  13. Funak

    Funak Chieftain

    Joined:
    Jul 15, 2013
    Messages:
    9,127
    and already incorporated :D
     
  14. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    You have a good point, the Whoward's mini-mods in the compatible list occupy too much of it and are distracting from the "big" mods. However:

    1. Gazebo is incorporating more and more of the mini-mods to CBP. Usualy when you manually add one of these mini-mods which is already part of CBP, the game will crash upon setup
    2. A few mini-mods became incompatible because of the changes in the promotion systems and units. E.g. the anti-aircraft guns get only anti-air promotions mini-mod or the mini-mod which changes the paratroopers

    So I think we should be tracking them somehow. Maybe remove them from the compatible list and keep only the ones in the non-compatible and incorporated in CPB lists? And link Whoward's page from the compatible list with a note "Most of these probably work if you cannot find them in the incompatible list ..."

     
  15. gaconff

    gaconff Chieftain

    Joined:
    Feb 8, 2011
    Messages:
    15
    Hello,

    Thank you for your list, it's really helpful.

    I see you state ethnic unit in there as compatible (with tweak) so I'm wondering will R.E.D work as well since the two (I assume) alter same area?
     
  16. Condotierri

    Condotierri Chieftain

    Joined:
    Nov 19, 2014
    Messages:
    34
    Reseed - Mod that let's you see the whole map and restart the map if you don't like it (can crash after restart, but it still saves the map in _reseed file so you can load from it after).
     
  17. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Hi,

    You are welcome.

    The 2 mods use the same graphic models for some units + R.E.D. tweaks formations and size of units which should be fine. The problem with the Ethnic Units mod was that it renamed the identifier of the Great War infantry (only!) so the game crashed when it tried to apply the new model on the renamed unit - meaning everything seemed fine until somebody reached the Modern era.

    I have not tried R.E.D. with CBP yet. I hope someone who has will report soon. If you try it out, please let me know the result and I will include it in the list. The thing is you can be sure for 100% only after you play the whole game (unless the game crashes right in the beginning - then we know it is not compatible :lol: ).
     
  18. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    UPDATE: Ok, I found out in another thread that someone reported R.E.D. was compatible, so I included it in the compatible mods list.
     
  19. gaconff

    gaconff Chieftain

    Joined:
    Feb 8, 2011
    Messages:
    15
    Thank you Vyyt, I tried to run a quick one with RED v 28 also, seem to work fine past modern era
     
  20. vyyt

    vyyt Chieftain

    Joined:
    Jan 28, 2005
    Messages:
    1,238
    Location:
    Czech Republic
    Great! So we have it double-confirmed now, thanks for the report.
     

Share This Page

Ebates: Get Paid to Shop