• Civilization 7 has been announced. For more info please check the forum here .

[NFP] New Frontier Pass

I got a reply from Aspyr. "The NFP mobile version aims to be released in the latter half of 2021, but details are undecided." Well ... I'll wait without expecting it.
Thanks for your efforts! I’m also waiting for the update. We will see when it comes.
 
That is great news! The game as it is works perfect on my iPad Pro and now to be able to try out the new content is fabulous.
 
They had some problems and the update didn’t happen although I I found the Vietnam and kublai khan inside the app purchases but I can’t even start a game yet so in short terms the game is broken now till they get the update up
 
Yes it’s out but am having a freeze when the world Congress arrives
Is anyone experiencing this ?
 
Here problems too. Update went fine, but in the game lots of things are broken. No tap and hold to get info on tile etc., minimap isnt working anymore. Its totally unplayable now. Going to try to delete and re-install everything now
 
Okay a complete clean install did the trick (so far).

update:
Not quite bug free for me. Seems that the new barb gamemode has a bug that makes the tile info unable to pop up. All other gamemodes works fine.
 
Last edited:
Anyone get cloud saves to work? The 2k Account button has been “offline” since release for me.
 
Had to do a new clean install also. Confirmed the Barb mode issue also, otherwise the game seems to run fine.
 
Last edited:
Well unfortunately when I purchased the NFP add on, it wouldn’t load. So I deleted CIv 6, cleared memory on my phone (20 GB free) and reinstalled. Base game loads fine, but when I restore purchases, very few install. No gathering storm or rise and fall add ons install, along with multiple leader add ons. Basically I get the base game with barbarian clans. Seems like a lot on money down the drain. I’ve tried reinstalling multiple times
 
So I backed up my iPhone and reset and erased my phone. Then did iPhone setup and backup restore. Once phone was back up an running, I prioritized Civ-6 download. Once it downloaded, I opened it and restored purchases. It worked perfectly. All purchases include NFP installed. All seems to be working well
 
Top Bottom