Please help me with error that causes a crash to desktop

Dec 11, 2005
I've been getting a crash to desktop every 3 or 4 turns. Just before it crashes a Civ4 window appears which reads:

fatal error: memory allocation problem
reason: bad memory allocation

I use the lastest BtS patch and I also use Wolfstanse mod.

Can anyone please help? Thanks in advance
Dec 11, 2005
I put all of the graphic settings on as low as possible and I still get the same crash; but a little bit less often.

I don't understand why this happening because I'm playing on my brand new computer. It's a Dell XPS 420 quad core, with 3600 RAM and a really good graphics card.

I am playing on a huge, New World map with 24 civilizations. But I'm still surprised that this is happening because my new computer is running everything else so fast.

Any thoughts? Thanks in advance
Dec 11, 2005
Originally Posted by Slyflyer
Ok, this is my first post in these forums and the main reason is because like so many of you I had the MAF errors in Warlords which annoyed me so bad. I mean, how could I play high end games like STALKER and Supreme Commander and have zero issues but have Civ IV screw up. I am running on Vista Business 32bit and this fix is geared toward any Vista OS but will work in XP too as far as I am aware of. I acctually got the idea from a fix for Supreme Commander and FSX where there were nastly bugs of CTD errors when to much memory was being used. I decided to give the fix a shot for CIV and see what would happen.... what happened is 3 hours of smooth bug free play in Warlords when the whole map had been discovered!

So here is my gift to you all.... enjoy!

Try this only if you have at least 2 GByte of RAM and at your own risk.

- First download the explorer from

- Next make a copy of Civ4Warlords.exe. Than start "CFF Explorer" and open the orginal Civ4Warlords.exe file.
- Now go to NT Header/File Header and click File Header. There you will find a button labeld "click here". Click it. And select the checkbox "App can handle> 2gb adressest "
- Save the modified EXE, overwrite the orginal one. (Note in Vista you must be running CFF Explorer in Administrator Mode).

If you run Windows Vista 64 or Windows XP 64 youre ready to go and dont need to read on. The rest is only for Windows Vista 32 and maybe Windows XP 32bit.

- Now we need to make Windows Vista (32-Bit) ready to support more than 2 GByte.
- Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".
- Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command window and press enter.
After that restart windows
- For Windows XP there is a similar setting for the boot.ini, but I am not sure what it is, should be found be google.


Are there any reasons not to do this? Can it hurt your computer?

I just tried it (for Vista 32 bit) and it makes a HUGE difference. Not only do I not get any MAF crashes, but I can run BtS on a huge map with all the graphic settings turned all the way up. I can even use 16 anti-alaising multi-sampling (I think it's called).

It seems almost too good to be true. Is it? Thanks in advance
Top Bottom