1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Prehistoric+Enlighment+FW Compatibility Patch

Discussion in 'Civ5 - Mod Components' started by Siskin, Apr 16, 2017.

  1. HMHG

    HMHG Chieftain

    Joined:
    Nov 29, 2019
    Messages:
    3
    I'm using Civ 5 full ver 1.0.3?? and the MODs which I enable are:
    1. Prehistoric Era v 28
    2. Enlightment Era v 7
    3. Future World v6
    4 P-E-F compatibility v4
    Without CBO
    In the game: My Tech tree broken.
    Hmm, but if I play just one mod (Pre or Enl or Fut), i can play no matter.
    My English is not good. But need some help. Please help me. I don't know how to this path can work.
     
  2. HMHG

    HMHG Chieftain

    Joined:
    Nov 29, 2019
    Messages:
    3
    It's not work ? Can you help me
     
  3. HMHG

    HMHG Chieftain

    Joined:
    Nov 29, 2019
    Messages:
    3
    Can you help me? I need you show all mod you used for play!!! I really want to play this mod
     

Share This Page