• Civilization 7 has been announced. For more info please check the forum here .

Problem Installing v1.21f Patch

jcc56

Chieftain
Joined
Apr 27, 2002
Messages
3
I'm running Civ3 v1.16f with the following system.
- Dell P3-800 MHz
- 128 KB
- GeForce256
- 40 GB HD (18 GB Free)

When trying to install v1.21f, the install file begins extracting files and attempts to launch the InstallShield Wizard. At that point I get the following error message: "Setup failed to launch installation engine: Error loading type Library/DLL"

I've previously installed patches like v1.16f with no problems. Any ideas on what is wrong? Doesn't look like others have had a similar problem.....

Any help would be appreciated.
 
FYI, for anyone interested.....I'm now working with Infogrames technical support to attempt to resolve. Based on what they've recommended so far it looks like something pretty fundamental with either the InstallShield program or some part of the operating system is broken. I suspect the problem is not directly related to the patch since I've updated successfully before and no one else appears to have had a similar issue.

I'll post the resolution when/if I get to one.
 
Problem solved!

The problem resulted from a system file that appears to have gone inexplicably missing. The file is STDOLE32.TLB which should be in the Windows\System folder. A friend emailed me a copy of the file (which I think should be somewhere on my Windows 98 CD but couldn't locate it easily) and once I copied it to the folder the installation worked perfectly.

The following article in the InstallShield Knowledge Base, ID Q104985 -- Initialization Error Troubleshooting lists several possible causes/fixes for the error I was experiencing. A message in their support newsgroup suggested that a corrupted or missing STDOLE32.TLB file is a very likely cause.

Hope this helps in the event anyone else ever encounters this problem. Now off to check out the new features of 1.21f!!!!:goodjob:
 
Top Bottom