Technical issue - Mod loading but has no (expected) effect


Oct 9, 2016
Hi all, a long long time CFC marauder asking help for the first time...

I used to create mods for my personnal use in Civ4 BTS 3.19, so i know the main processes to have something working correctly, before you ask.

I recently went back to modding after a long time. Something simple, just adding few units. But it appears that when i launch the mod, it's loaded (the name appears in the top right corner of the screen) , but no changes appears: new units are not present in pedia, neither in worldbuilder; it's just like the vanilla.

I tried to load other mods i have built on an other computer (runing on windows 7) . They work fine, i m even able to edit them on the new one. But all new mod i try to create on this new machine are uneffective.

I found no post corresponding to my issue. Does anyone have a clue?

(I have the DVD complete edition (Vanilla+Warlords+BTS) patched in 3.19, loading correctly on windows 10)

Could you be a bit more specific? As in do you manually load your new mod? Do you have all the appropriate files inside the mod folder etc?
Well, inside the directory, i have everything i usually put (\art, \xml, with all relevant subfolders and files in)...

I always work the same way:
- creating a folder (out of the game folder)
- in, creating a \assets
- putting in a clone of the BTS folder for XML
- creating an empty art folder and filling it with the necessary files

- tree looks like this: ModName\Assets\art\

- editing unitclassinfos/unitinfos/text/artdefines_unit for each unit in that order (and no other)
- copying the whole folder in the mods folder (in my case D:\Jeux\Sid Meier's Civilization 4 Complete\Beyond the Sword\Mods\)
- loading the game, launching the mod, checking everything is displaying correctly
- if so, finally, i work on the mod itself (unitstats, properties, etc...) in the original directory (not the one in the game mod folder)

I've done this way for a more than a decade and never got such a "non-result" ! As I already said, i m able to edit existing mods and get the new content working, but not from scratch.

EDIT: i ve just made a test with only adding ONE xml unit (no graphic change) and it works. This means there s something wrong with the graphics.
Am i right?
Can one unit graphic (NIF) drive to such a problem? I already had errors or crashes, but it was a matter of typo in art defines. And i've checked five or six times (not sure) all was correct...
Last edited:
A clone of the entire BTS folder? Or do you mean just the XML subfolder? You don't have to do that. Just add what ever XML files you want. In fact, as far as I understand even the folder structure is basically unimportant and only serves for our convenience.

But yes, it sounds to me like the nif file might be the problem. Bad or broken nif files can cause no end of problems. Upload it here and we'll take a look.
Ok. Do you want me to upload the whole mod, or just the art folder?
Put everything in a zip file and I'll look at it tomorrow.
Here it is.
Have a look at the text file in the xml folder to find quickly the changes i've made.
I also modified the vanilla artillery art, but i don't think this one is the problem, unless i've messed something, and despite my checks.


  • Varna's
    3 MB · Views: 26
I won't be able to test it for another 24h or so due to stuff I have to do. But until than I just want to tell you that you don't have to copy all the XML files. Just copy the one you want to change. Some conflict relating to that might even be causing your problem.
Thanks. I have many things to do too, so do what you can when you can.
On the XML subject, i realized i've misspoken. I copy the files I need, just like you say. I just copied the near whole folder for the last mod i was working on, because i was expecting many changes; but for this one, i only copy the files to edit the units stats & art, with sounds relatives and effects.
(It has been a long time i haven't made something so simple...)
Problem solved, you can forget about it. It had several errors, i just erased evrything an d now it works.
Top Bottom