[GS] Unit art is causing the game to crash!


Apr 11, 2016
Malachor V
Hey all,

I'm attempting to (finally) update one of my mods for Gathering Storm, but there's an issue - the game keeps crashing to desktop at the dawn of man screen! I've had trouble like this before in the past so it's almost certainly an issue with the artdefines or their reference in the mod art file.

Having tested around a bit, I've managed to isolate the issue to the unit in my mod file; strangely, removing the unit file (which is separate from the infrastructure, civilization, and leader - the last of which is in a separate mod entirely -) stops the crash and allows the game to load just fine. I've tried doing everything I know to do - replace Units.artdef, use an older version of the file (in case it got corrupted somehow), even rewrite the SQL (which by all accounts wouldn't have worked anyways, but I'm desperate) - but to no avail.

FWIW, I should mention that I'm not using any custom assets either. The artdef only references existing values for the Infantry that it replaces.

So, I've come to you guys for help. All the files referencing the unit are attached below if anyone wants to have a looksie. Help would be very much appreciated!


  • PlsHelpKayThxBai.zip
    6.9 KB · Views: 85
Top Bottom