[We the People] Bug reporting

When clicking the "sail to Africa" button my ships now just lose all their moves for the turn without actually moving and getting any closer to Africa :p
Something that has never happened before..
 

Attachments

  • test_save.ColonizationSave
    630.9 KB · Views: 4
Does your ship have a valid path to the ocean?

A storm can block the pathfinder - if the storm tile(s) is part of the only valid path the pathfinder will skip the ships turn and wait until the storm has cleared.

Regards
XSamatan
 
Does your ship have a valid path to the ocean?

A storm can block the pathfinder - if the storm tile(s) is part of the only valid path the pathfinder will skip the ships turn and wait until the storm has cleared.

Regards
XSamatan
That might have been it, I don´t know. I kept playing and the feature started working properly again.
 
Hello,

First, this an absolutely incredible mod. The time and effort you all have put into this over years is absolutely incredible. Thank you so much for all your work.

Second, I'm encountering a bug where the turn won't end. Upon clicking the end turn button, the cursor starts spinning and nothing happens. I let it run for an hour last night. The game doesn't crash, and my computer continues to run in the background, but I can't switch to any other windows despite being able to open them from the task bar. The game is said to be not responding in task manager, but can't be closed from that, or by closing the window. The only way out of it seems to be restarting my computer. The error happens at the same turn number each time. I've attached a save file, hitting end turn should reproduce the error.

Thank you again.
 

Attachments

  • Crash_SaveAD-1530-May.ColonizationSave
    504.6 KB · Views: 4
Last edited:
Second, I'm encountering a bug where the turn won't end. Upon clicking the end turn button, the cursor starts spinning and nothing happens. I let it run for an hour last night. The game doesn't crash, and my computer continues to run in the background, but I can't switch to any other windows despite being able to open them from the task bar. The game is said to be not responding in task manager, but can't be closed from that, or by closing the window. The only way out of it seems to be restarting my computer. The error happens at the same turn number each time. I've attached a save file, hitting end turn should reproduce the error.
Technically the game hangs rather than crashing. It happens when the code does "repeat until some condition, which will never happen". The end result is the same through as it makes the game unplayable. I will investigate this ASAP.

EDIT: looks like it isn't hanging when using the development version. In other words the bug has been fixed, but not released yet.
 
Last edited:
Technically the game hangs rather than crashing. It happens when the code does "repeat until some condition, which will never happen". The end result is the same through as it makes the game unplayable. I will investigate this ASAP.

EDIT: looks like it isn't hanging when using the development version. In other words the bug has been fixed, but not released yet.
Thank you very, very much for looking into this, and the update. You guys are the best.
 
Hi guys, just launched a new game and I got my hands on Ivan Aleksandrovich Kuskov. He adds everything he should, but the 'Small Coastal Ship' is dropped in Europe (playing the Netherlands) instead of 'Nieuw Amsterdam'. It can set sail to the new world, but when it arrives, it cannot move through ocean tiles (as supposed to). I could send it back to Europe, but there it has no option to sell it. So the only thing left is, delete it on the ocean.
 
Hi guys, just launched a new game and I got my hands on Ivan Aleksandrovich Kuskov. He adds everything he should, but the 'Small Coastal Ship' is dropped in Europe (playing the Netherlands) instead of 'Nieuw Amsterdam'. It can set sail to the new world, but when it arrives, it cannot move through ocean tiles (as supposed to). I could send it back to Europe, but there it has no option to sell it. So the only thing left is, delete it on the ocean.
Spawning in Europe is something, which is done if the game for some reason can't find a suitable colony, like it requires a non-full harbor or a deep harbor (some ships) etc. Having a coastal ship in Europe is the fallback gone wrong. I will admit that it is likely this specific case wasn't considered when the code was written and while I did modify the code at some point later to fix an issue, I might not have considered this specific case either.

This is one of the hard parts about programming what is in some ways a sandbox game. The ship should be in a colony, but what if natives destroyed your original colony and your only remaining colony is inland? Where should the ship appear? The game seems to be good at endlessly finding unlikely scenarios where something breaks.
 
Spawning in Europe is something, which is done if the game for some reason can't find a suitable colony, like it requires a non-full harbor or a deep harbor (some ships) etc. Having a coastal ship in Europe is the fallback gone wrong. I will admit that it is likely this specific case wasn't considered when the code was written and while I did modify the code at some point later to fix an issue, I might not have considered this specific case either.

This is one of the hard parts about programming what is in some ways a sandbox game. The ship should be in a colony, but what if natives destroyed your original colony and your only remaining colony is inland? Where should the ship appear? The game seems to be good at endlessly finding unlikely scenarios where something breaks.
Hehe, Nieuw Amsterdam was still in existence, but since I already had the event of the galleon due to a bunch of found treasures, you might be right with the full harbour at that very moment. I guess it was just a bad coincidence then. A situation like that probably wouldn't happen to often and, truth to be told, whoever considers to use transports on rivers would probably rather use the bigger versions anyway. To me it wasn't too much of a loss. Just thought if it was a maybe unnoticed bug I should mention it ;)
 
Hi, i´m absolute liking the Game and the effort you guys put in to the mod, but i encounter a massive problem with breeding: every animal vanishes when it´s enters my borders, as you see in the pic. Sometimes it´s reversable, but only on normal speed, and i like to play Civ-Games slow. The installation is clean, and i verified it also with the github; is this a bug or missed I something major?
 

Attachments

  • Bild_2024-02-27_220215174.png
    Bild_2024-02-27_220215174.png
    2.2 MB · Views: 73
Hi, i´m absolute liking the Game and the effort you guys put in to the mod, but i encounter a massive problem with breeding: every animal vanishes when it´s enters my borders, as you see in the pic. Sometimes it´s reversable, but only on normal speed, and i like to play Civ-Games slow. The installation is clean, and i verified it also with the github; is this a bug or missed I something major?
Production of animals depend on how many you already have. 0 horses*(whatever the plot provides) is 0. Get some horses/cows/sheep from Europe and make them breed.
 
Hi, i´m absolute liking the Game and the effort you guys put in to the mod, but i encounter a massive problem with breeding: every animal vanishes when it´s enters my borders
When a tile is outside your border it shows all the things that can grow there, but when it is inside your border it only shows what it can grow given the resources in the city. To get the animals "back" you need to unload some in the city.

It would be nice if they stayed visible but were outlines or something.
 
I think I've discovered a nasty bug within the transportation routes.
One city gets too much of all goods totally ignoring the import limits and also the warehouse limit.
Apparently this things are not checked when unloading goods ...

1712314311638.png

The DLL used was compiled yesterday from branch development.
I have observed this behavior several times, but have not paid any further attention to it ...
 
Hello again folks, back with another bug report.
I'm playing with the Mod-Develop code compiled on March 18th, and I've been noticing that quite often the maps without fixed leaders (Northwest Passage, Colonial America) end up breaking or throwing a lot of Python exceptions.
Would the existence of two George Washingtons do it? lol

In a different save I declared war on one for the settler and then the next turn I got the introduction screen to the second Washington, and then about a thousand python exceptions appeared.

Attaching my save here. Thanks for all the work you guys do!
 

Attachments

  • image_2024-04-07_132052618.png
    image_2024-04-07_132052618.png
    768 KB · Views: 34
  • swedentwopioneermiddle.ColonizationSave
    156.5 KB · Views: 2
Would the existence of two George Washingtons do it?
Quick. Rewrite the history books. Pietre61 just discovered that George Washington suffered from multiple personality disorder.

No idea what is going on with the python errors, but I do have a hunch that it might not work with the current scenario reader, which happens to be written in python. No idea how that would break as nobody touched it in ages.
 
Hello again folks, back with another bug report.
I'm playing with the Mod-Develop code compiled on March 18th, and I've been noticing that quite often the maps without fixed leaders (Northwest Passage, Colonial America) end up breaking or throwing a lot of Python exceptions.
Would the existence of two George Washingtons do it? lol

In a different save I declared war on one for the settler and then the next turn I got the introduction screen to the second Washington, and then about a thousand python exceptions appeared.

Attaching my save here. Thanks for all the work you guys do!

The very next world: Maybe I shouldn't play on the development branch heh
1712493094135.png
 
Easy one:
Domestic Advisor / Storage House Screen
The sort function is not working properly. Sorting is done by text, not by numbers. For example, in the first picture, ascending sorting is used. 115 is the first, when it was supposed to be after 45.
In the second pic, descending sorting example: 128 is the last because it starts with '1'. It should've been first.

I guess that all you have to do is to change the sort type or the array type in the DLL.

See screenshots.
2024-04-12 00_08_16-Window.png
2024-04-12 00_08_34-Window.png


P.S. Kudos for this amazing mod and your fantastic efforts.
 
Pathfinding going thru Rock Reef, based on Mobility I and not avoid the damage in the process.
None of the tiles around the Rock Reef have movement penalty.

Develop version as of 04/15/2024 and the save file has the ship ready for movement.

 

Attachments

  • DEV - V turn in progress.ColonizationSave
    777.5 KB · Views: 1
  • 20240415140913_1.jpg
    20240415140913_1.jpg
    330.7 KB · Views: 25
  • 20240415133309_1.jpg
    20240415133309_1.jpg
    502.2 KB · Views: 43
Can`t found settlement inside own borders (1 tiles to nearest city, reduced distance is on, 3x3 plots are owned)
 

Attachments

  • 1.png
    1.png
    4.5 MB · Views: 28
  • 2.png
    2.png
    3 MB · Views: 30
  • John AD-1631-January.ColonizationSave
    805.2 KB · Views: 2
Reproducable bug on latest devbranch(post4.1).
It appears when capturing the british colonie plymouth(probably last in new world)
BuggySave
ModName: Barra
(btw. is there a way to edit a saves mod dependancy? )
Edit:
It depends directly to the colony, if the colony switches owner using worldbuilder, it immediatly crashes after closing worldbuilder, aswell when burning the city
 
Last edited:
Top Bottom