Crash to Desktop Upon loading Map

Karl Townsend

Prince
Joined
Dec 27, 2005
Messages
429
Tried these possible fixes and none have worked, i might go as drastic as reinstalling windows but if anyone has a work around to this please share

My problem

upon loading a map i get a Civilization V has stopped working (No error message)

My Computer

Windows Vista (Business)
AMD Phenom 9850 (quad 2,5 ghz)
4 GB of ram
nvidea 9600 GT
M3a Mainboard

Works and Fixes i have tried

  • Various detail settings tried all at minimum and maximum detail
  • Window Mode
  • Reinstalling Civ 5
  • Disabling steam in game interface
  • Disabling Steam cloud
  • Updating video drivers
  • Installing Beta Video drivers.
  • upgrading to DirectX 11
  • Running in DX 9 and 11 mode
  • Trying different map sizes
  • Rebuilding the C++ Runtime Libraries
  • Updating to service pack 2

If anyones got a fix i would really love to know my computer falls well into the reccomended specification and i would really love to play the new Civ (I Dont wanna be stuck playing 4 T_T even if it was awsomeness)

Edit : Currently trying to validate the game files (1 has failed and will be reacquired)
Edit 2 : This file seems to be constantly invalid

- Karl
 

Karl Townsend

Prince
Joined
Dec 27, 2005
Messages
429
Does validating mean checking the integrity of the game cache?

im not to sure, ive tried delete civ 5's cache folder which didnt work , all it will do is find the corrupted file and re download it which is inherently corrupted

it just might be a user file that encrypts is self once it is accessed i not sure, it dosent give me a specific file.

in the mean time i found this

Civilization V Troubleshooting Guide

1# Civilization V Crashes and Poor Performance on ATI Cards
It is highly recommended that you have the latest Catalyst drivers for your card. Download and install the latest v1.52 patch if you are having initialization issues with your ATI Graphics Card.

2# Crashes and Bad Performance on nVidia Cards
Updating your display drivers will help the cause.

3# Civilization V “Out of Memory” Error Fix
This is due to deficiency of your Video memory. So reducing the graphics to lower settings may help the cause. If it does not solve your problem then find this value in the config(ini) file, “HideOutOfVRamWarning” and set HideOutOfVRamWarning = 1 using notepad. This should remove the warning message.

4# Civilization V Error Code: -5009 : 0x8000ffff
There are 2 solutions for this one:
Clean out the temp folder. If you are not sure that what is the exact location of this folder then open command prompt and type “set temp” to see the path then go to that folder and delete all the files/folders within it.
Fix Corrupt Install Shield files. Go to

C:\Program Files\Common Files\InstallShield\Professional\RunTime

and delete or rename IsProBE.tlb then re-run the installer.

5# Civilization V Crashes on Startup, Skip Intro Movie
If your game keeps on crashing at the initial stages of the game like the start up screen or the first loading screen, you may want to try following workarounds.
1. Go to

“My Documents\My Games\Sid Meiers Civilization 5\”

and open usersettings.ini in Notepad. About 15 lines down you will find “SkipIntroVideo = 0?. Make this value 1. This will skip the intro video and you will be directly enter to the game menu. Again, make sure that you have the latest drivers and you reboot the PC after driver install and editing the ini file.

2. Navigate to

Steam/SteamApps/common/Sid Meier’s Civilization V/DirectX

and run Dxsetup.exe. if you are using Dx10/11, try running the game using DirectX 9 also upgrade your DirectX drivers.

6# Civilization V Crashes on Large Maps
It is most probably due to the fact that you have LOW memory (RAM). You can avoid crashes by terminating other process that might be consuming your memory.

7# Civilization V Black Screen Out of Range Error
Right click on ‘Civilization V’ in Steam -> Properties -> Set launch options. Add “-w 1024 -h 768 -refresh 60?. Run the game, and change video settings in game options to this resolution and refresh rate.
It happens because your monitor doesn’t support default resolution. Remove this command line after you have changed the video settings.

8# Unable to Load .dll file
Verify the integrity of the files.

9# Executed Civilization V executable, and nothing happened ?
Try running the game as admin, or in Windows XP SP2 compatibility.

10# Civilization V Failed to Launch
If you have tried launching the game after installation and nothing happens, any error occurs, you can try these workarounds to fix the launch issues of the game
1. Restart Steam.
2. Restart Computer.
3. Go the folder and launch the application directly.
4. Validate integrity of game cache.
If that Doesn’t work, try this.
Go the folder in your steam index/common/civilization v
delete the Type. file “srcds_run” and then re-validate the integrity of game cache.

11# Broken DirectX 10 DirectX 11 Launcher Fix
If you get DirectX error on running the launcher. In order to fix that go to properties of Steam.exe and ensure that ‘Compatability mode’ is turned off.
Click ‘Change settings for all users’ in order to un-grey the Compatibility mode, but after that everything will work perfectly fine.

12# Civilization V Multiplayer Connectivity Issues
13# Civilization V Random Lag Spikes
Experiencing random ping jumps and lag issues ?. ALT-TAB out of the game, go to taskbar>processes and see which processes are loading your processor and causing these spikes. Also make sure you meet the minimum requirements in order to play the game.

14# Civilization V Crashes When Opening Civlopedia
Run the game in DirectX 9 and it will resolve this issue.

16# Problems Starting Civilization V Demo
Try to play the demo in compatibility mode DirectX 9 and see if the game starts properly.

17# Game Won’t Install From Disc ? Requires Download From Steam
Some of the users have reported that the disc version of the game they bought requires download from steam. If you face this problem you can try deleting all the game files and re-install the game using setup.exe from the disk. Or you can refer to the tutorial below on how you can install the game from the disc instead of steam.

How to Use Steam launch options to install retail games from disc.
1. Log in to Steam and click on Library.
2. Right-click on the game, select Delete local content, and confirm.
3. Insert the first disc into your computer.
4. Close Steam (Steam > Exit).
5. Press Windows Key + R to open Run
6. In the Run window type:

“C:\Program Files\Steam\Steam.exe” -install E:

Replace E: with the CD/DVD drive you are installing from if is not correct.
Replace C:\Program Files\Steam if your Steam installation is not in the default location.
7. Press OK. Steam will launch and ask you to sign in if you do not have your password saved. Your installation should continue from the disc.

18# Anti Aliasing Doesn’t Work with DirectX 10/11
Playing the game in DirectX 10/11 ? some of you may experience no anti-aliasing whatsoever.
If you face this issue, go to GraphicsSettingsDX11.ini in your “My Games\Sid Meier’s Civilization V” folder and change “AllowLeaderAA” to “0? to fix it.

19# DirectX 9, DirectX 10, DirectX 11 Permanent Fix
Install “DXSetup.exe” from steamapps\common\sid meier’s civilization v\directx and it will resolve all your DirectX problems.

20# Can’t Save Games on Local Hard Drive
At your desktop, navigate to your “My Games” folder then to the “Sid Meier’s Civilization 5? folder. Find the Config.ini file, right click and select “Edit”.

Scroll down to the section [Game], which is about 75% down the list. The third option under that is what you are looking for. It will look like this:

; Save Path – relative to working (Civ5) folder
FileName =

You need to put in the directory location of the “Saves” folder in the blank spot after FileName =

It should then look similar to this (check your own directory, it is different on different OS):

FileName = C:\Users\(Your Username)\Documents\My Games\Sid Meier’s Civilization 5\Saves\

Save the Config.ini file after your modification and congrats now you will be able to save games on your local hard drive.

21# Civilization V Bonus Content and Sound Tracks Location

C:\Program Files\Steam\steamapps\common\sid meier’s civilization v\Assets\DLC\DLC_Deluxe\Soundtrack

These are currently the major issues reported by users. If you face any other issue, share with us and we will try to resolve any issue faced by you.

Found at the IGN Boards
i do not take credit for this hope it fixes some problems i might try fixes 3 and 4 when i get home from work
 

The_J

Say No 2 Net Validations
Administrator
Supporter
Joined
Oct 22, 2008
Messages
37,420
Location
DE/NL/FR
im not to sure, ive tried delete civ 5's cache folder which didnt work , all it will do is find the corrupted file and re download it which is inherently corrupted

In steam, go to library -> civ5 -> properties/settings/orSimilar (i'm sitting on a german pc, so i don't know the exact translation), and there should be an option to check the integrity.

in the mean time i found this

o_O the fist tip is for Civ4, the rest seems to be valid, but nothing applies to you, as far as i can see.
 

Karl Townsend

Prince
Joined
Dec 27, 2005
Messages
429
In steam, go to library -> civ5 -> properties/settings/orSimilar (i'm sitting on a german pc, so i don't know the exact translation), and there should be an option to check the integrity.

yes its the same thing, tried defragging as well.
 

Karl Townsend

Prince
Joined
Dec 27, 2005
Messages
429
Bump T_T
2 Patches still no fix to this

Edit Some stuff i manged to get from a crash report (Didnt know these were in the main civ folder)

Code:
winver: 5.1.2600 (id=2). SP=2.0. SM = 0x300.
sysinf: 0, 4096, 0x65536, 0x2147418111, 0xf, 4, 586, 65536, 16, 515
cpufea: Y, N, Y, N, N, N, N, Y, Y, Y, Y, Y, Y, Y
DXDIAG
-----

szDeviceName = Failed to get parameter
szDescription = Failed to get parameter
szKeyDeviceID = Failed to get parameter
szKeyDeviceKey = Failed to get parameter
szManufacturer = Failed to get parameter
szChipType = Failed to get parameter
szDACType = Failed to get parameter
szRevision = 
szDisplayMemoryLocalized = Failed to get parameter
szDisplayMemoryEnglish = Failed to get parameter
szDisplayModeLocalized = Failed to get parameter
szDisplayModeEnglish = Failed to get parameter
dwWidth = 1920
dwHeight = 1080
dwBpp = 32
dwRefreshRate = 60
szMonitorName = Failed to get parameter
szMonitorMaxRes = 
szDriverName = Failed to get parameter
szDriverVersion = Failed to get parameter
szDriverAttributes = Failed to get parameter
szDriverLanguageEnglish = Failed to get parameter
szDriverLanguageLocalized = Failed to get parameter
szDriverDateEnglish = Failed to get parameter
szDriverDateLocalized = Failed to get parameter
lDriverSize = 10022504
szMiniVdd = Failed to get parameter
szMiniVddDateLocalized = Failed to get parameter
szMiniVddDateEnglish = Failed to get parameter
lMiniVddSize = 0
szVdd = Failed to get parameter
bCanRenderWindow = true
bDriverBeta = false
bDriverDebug = false
bDriverSigned = false
bDriverSignedValid = false
szDeviceIdentifier = Failed to get parameter
szDriverSignDate = 
dwDDIVersion = 10
szDDIVersionEnglish = Failed to get parameter
szDDIVersionLocalized = Failed to get parameter
szBGRASupported = true
iAdapter = 0
szVendorId = Failed to get parameter
szDeviceId = Failed to get parameter
szSubSysId = Failed to get parameter
szRevisionId = Failed to get parameter
dwWHQLLevel = 0
bNoHardware = false
bDDAccelerationEnabled = true
b3DAccelerationExists = true
b3DAccelerationEnabled = true
bAGPEnabled = true
bAGPExists = true
bAGPExistenceValid = true
szDXVAModes = Failed to get parameter
szDDStatusLocalized = Failed to get parameter
szDDStatusEnglish = Failed to get parameter
szD3DStatusLocalized = Failed to get parameter
szD3DStatusEnglish = Failed to get parameter
szAGPStatusLocalized = Failed to get parameter
szAGPStatusEnglish = Failed to get parameter
szNotesLocalized = Failed to get parameter
szNotesEnglish = Failed to get parameter
szRegHelpText = 
szTestResultDDLocalized = Failed to get parameter
szTestResultDDEnglish = Failed to get parameter
szTestResultD3D7Localized = Failed to get parameter
szTestResultD3D7English = Failed to get parameter
szTestResultD3D8Localized = Failed to get parameter
szTestResultD3D8English = Failed to get parameter
szTestResultD3D9Localized = Failed to get parameter
szTestResultD3D9English = Failed to get parameter
sysmet: 0,1,8,1920,1030,1920,1080,0,0,1,1,0,1,0,0,0
names : KARLS-PC, Karl
window: C:\Windows
progrm: C:\Program Files
prog86: C:\Program Files
appdat: C:\Users\Karl\AppData\Roaming
mydocs: C:\Users\Karl\Documents

Rest is just unreadable garbage
 

Karl Townsend

Prince
Joined
Dec 27, 2005
Messages
429
1920 resolution...please try a smaller one.
There's one report in the bug forum, in which someone investigated the resolutions, and only the ones below 13xx were completely stable.


Nope still crashes in 1024x768
 

Pinkmagus

Chieftain
Joined
Sep 22, 2010
Messages
4
I get this bug always, any map, any setting. Just loads with narration fro the Leader Head, and then suddenly the audio skips and BAM, crash.
 
Top Bottom