1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

I need help on deleting saved games for civ4 on macintosh computers...

Discussion in 'Civ4 - Macintosh' started by echung, Feb 27, 2008.

  1. echung

    echung Chieftain

    Joined:
    Feb 27, 2008
    Messages:
    2
    I try to delete saved games on my apple computer because it's eating up my space. but no matter what, i can't seem to delete the games i save. :sad:
     
  2. echung

    echung Chieftain

    Joined:
    Feb 27, 2008
    Messages:
    2
    can anyone help me with this problem?

    Moderator Action: Welcome to the forum :wavey: ...
    ... but please don't expect replies in minutes, I just doesn't happen! You were lucky to get a response within two hours.
     
  3. s.bernbaum

    s.bernbaum Mostly lurking

    Joined:
    Dec 2, 2006
    Messages:
    2,771
    Location:
    The wilds of Montana
    Go to ~/documents/Civilization IV/Saves/ folder in Finder. In there you will see several other folders: single for single player games, multi for multiple player online games, PBEM for Play by Email games, etc. Open whichever one is the type that you want to delete games from. I am guessing that you probably playing single player games. In the "single" folder you will find a "Quick" and an "Auto" folder and all the games that you have saved by choice. Delete any games that you want to clear out. If you have been using Quick Save then open the Quick folder and delete any of those that you want to get rid of. The auto folder gets cleaned out by the game every time that you start a fresh game but you can clean that one out too, if you want. You delete the files the same way that you would delete any other file in Finder.
     
  4. KhanFusion

    KhanFusion Chieftain

    Joined:
    Jul 28, 2013
    Messages:
    1
    I can't find that documents folder with Civilization IV/Saves. I've also searched for civ4savedgame extension. The Apple directory structure is sooo diff fr PC, I'm wondering if there is a setting that disables seeing my application files.
     
  5. AlanH

    AlanH Mac addict, php monkey Moderator Hall of Fame Staff Supporter GOTM Staff

    Joined:
    Jan 9, 2003
    Messages:
    29,317
    Gender:
    Male
    Location:
    England
    Hi, welcome :wavey:

    ~/documents/Civilization IV/Saves/ is the location for all vanilla saves. '~' means your Home folder, so the full path is: '/Users/<your_name>/Documents/Civilization IV/Saves/'

    There's another one for Warlords:

    /Users/<your_name>/Documents/Civilization IV Warlords/Saves

    ... and another for Beyond The Sword:

    /Users/<your_name>/Documents/Civilization IV Beyond the Sword/Saves

    None of them should be hidden. If you can't find 'Documents' in a Finder window, try using the Go menu.
     
  6. Gilgalad

    Gilgalad Chieftain

    Joined:
    Aug 23, 2011
    Messages:
    18
    Or do a search for the name a game is saved under, like "Gilgamesh" or whatever. Make a note of the file tree when the search comes back.

    I made an alias of the save folder and left it on my desktop so I can quickly delete old game files.
     
  7. runningfrog

    runningfrog Chieftain

    Joined:
    Sep 24, 2015
    Messages:
    2
    Location:
    13 countries and counting
    I realize I am posting two years later, about a game that came out ten years ago... But since I literally came here today with this exact same problem and spent an hour trying to blunder my way through it, there might be a chance this helps someone else.

    I had same issues as earlier posters. Roughly 4 gigs of saved games on my MacBook Air and no way to find them to get rid of them. Running 10.8.5 and the previous advice about searching for file names or looking in my documents folder was of no help. At some point, Apple moved all that stuff, and none of it is searchable any more, even if you know the file name.

    I got lucky because when I went to save a game this morning, it was using a name I had already used, and the error message popped up with the exact file path for the file I was asking to rewrite.

    Civ IV saves on a Mac running 10.8.5 are found in:
    \Users\yourname\Library\ApplicationSupport\CivilizationIV\Saves (and then \Single in my case and probably yours if you are here with gigs and gigs of saved games yourself)

    Even if you know the file name, it will never be found by searching. Search won't look in application support libraries. So you have to go there directly.

    As stated by an earlier poster, you won't find Library on your own either. Library is hidden by default, as part of Apple's method of keeping users from accidentally damaging important files. So to get there, you will have to run Terminal (under Applications\Utilities) and then paste this command:

    defaults write com.apple.finder AppleShowAllFiles YES

    After doing so, you have to relaunch Finder by Control-Option-clicking the Finder icon on your dock and clicking the bottom option for relaunch. Now when you open a Finder window again, you can follow the path I listed above to get to the Library and Application Support and ultimately to your saved games.

    If you want to no longer see all your invisible files, you can go back into Terminal and paste this command

    defaults write com.apple.finder AppleShowAllFiles NO

    Then relaunch your Finder using the control-option-click on the icon, and you are back to blissful ignorance of all the secret files you don't need to know about.

    I hope this helps someone else. :)
     
    Noble Zarkon likes this.
  8. diggler

    diggler Chieftain

    Joined:
    Nov 3, 2015
    Messages:
    5
    I found mine in \Users\yourname\Library\ApplicationSupport\CivilizationIV\User\Saves and then \Single
     
  9. JCMiller23

    JCMiller23 Chieftain

    Joined:
    May 12, 2009
    Messages:
    13
    Props to RunningFrog for helping me figure this one out. It's in the same spot for me as he described in his post; I'm running OSX Lion 10.7.5. It didn't work at first, but then I realized I needed to restart Finder in order for it to reset its display preferences. I did this by entering the command "killall Finder" after entering "defaults write com.apple.finder AppleShowAllFiles YES"
     

Share This Page