[BTS] (Linux) Upon Steam launch I get XML Errors, Can't launch game


Nov 28, 2021
I was able to play BTS on my machine for some years now and have racked up more than 400 hours on it. However, recently (within the last few months) I have been unable to play at all.

I first noticed the problem with RFCE. Again, I have been able to play that mod on this machine for some time without major issue. However, RFCE started to give me XML errors and would not load. All of my other mods and the base game continued to work fine at this time. As I had other things to do I simply stopped playing RFCE as I assumed it was a problem with the mod itself.

Some months later, I discovered that I could not launch BTS at all now, with XML errors showing. I am not sure what triggered this to occur as nothing in particular has changed about my system. All of my other Steam games work without this issue.

The XML errors are :
1)Failed Loading XML File xml\GameInfo/CIV4PlayerOptionInfos.xml
2)LoadXML call failed for GameInfo\CIV4PlayerOptionInfos.xml
3)Failed Loading XML File xml\GameInfo/CIV4GraphicOptionInfos.xml
4)LoadXML call failed for GameInfo\CIV4GraphicOptionInfos.xml

I am not sure if these were the same XML errors that RFCE had.

Steps I have taken:
I. Verified Integrity of Game files (no change)
II. Uninstalled and reinstalled BTS (no change)
III. Uninstalled and deleted files of BTS that Steam does not delete and reinstalled (no change)
IV. Installed base Civ 4 (got same xml errors)
V. Used different proton versions including Proton Experimental (no change)

My system info:
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.2-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
Memory: 13.6 GiB of RAM
Graphics Processor: AMD Radeon Vega 8 Graphics

If this is an issue that has already been solved I apologize in advance but I was not able to find anything. Any help in this matter would be appreciated.


Rock N Roller
Sep 17, 2010
I don't use steam so don't know if the problem is connected to that, nor do I use Manjaro. However, the game does work well for me with a GOG install on Linux Mint, so it is definitely possible. Those XML errors don't tell me much unfortunately, and if they were faulty for some reason, surely reinstalling the game should have fixed it.

Maybe there have been some updates to Manjaro or drivers that has somehow caused things to malfunction?

Perhaps this won't be terribly helpful given you are on a different system and all, but this is the install that I used, which still has the game working well: https://www.gog.com/forum/sid_meiers_civilization_series/civilization_iv_for_linux
Top Bottom