1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

MODs compatible with Community Balance Patch (CBP)

Discussion in 'Community Patch Project' started by vyyt, Jan 29, 2015.

  1. busted_bunny

    busted_bunny Chieftain

    Joined:
    Jun 13, 2017
    Messages:
    43
    Gender:
    Male
    Yeeaah :cool:
    I made Emigration mod "kinda" compatible with VP happines. Now it works good to me.
     

    Attached Files:

    Asterix Rage likes this.
  2. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,322
    Location:
    Czech Republic
    I updated the compatibility lists and included a link to your post. Thanks!
     
  3. pbobbert

    pbobbert Chieftain

    Joined:
    Jun 30, 2017
    Messages:
    15
    Gender:
    Male
    Does anyone know if there is a version of VP that only has the changes to the happiness system? I really like the looks of it, but the rest of VP is just to much change for me.
     
  4. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,322
    Location:
    Czech Republic
    Nope, it is too intertwined with other game mechanics.

    The scale of the overhaul may be daunting at first, but you will get used to it quickly, don't worry. VP is much more fun than vanilla Civ5, you won't regret if you give it a try.
     
  5. Enginseer

    Enginseer Salientia of the Community Patch Supporter

    Joined:
    Nov 7, 2012
    Messages:
    3,228
    Gender:
    Male
    Location:
    Somewhere in California
    The irony was that CBP was intended to have separate mechanics balanced out, but as the CBP progressed significantly the overhaul became too much of a burden to separate into components.
     
    vyyt likes this.
  6. pbobbert

    pbobbert Chieftain

    Joined:
    Jun 30, 2017
    Messages:
    15
    Gender:
    Male
    That's too bad, the happiness system looks cool. Unfortunately the rest of VP conflicts with my other mods.

    That said, does VP work with the multiplayer workaround mod?
     
  7. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,322
    Location:
    Czech Republic
    You mean if you can create a "fake DLC" from VP and play it in multiplayer? Absolutely, the latest one is here:

    https://forums.civfanatics.com/threads/7-11-17-modpack.619847/

    I know I sound like a VP fan boy and I am a VP fan boy, but I cannot imagine there would be a mod worth giving up VP for. Have you checked the lists in the beginning of this mod compatibility thread? Are you sure the other mods cannot be made compatible with VP? BTW I am really not getting paid by the devs for converting people to VP, I promise :)
     
  8. pbobbert

    pbobbert Chieftain

    Joined:
    Jun 30, 2017
    Messages:
    15
    Gender:
    Male
    I prefer the changes proposed in Ackens balance mod, but primarily Cultural diffusion is listed as non compatible, as well as Revolutions. I also use Emigration but it looks like someone just solved that problem.
     
  9. YINGCHENG

    YINGCHENG Warlord

    Joined:
    Oct 25, 2016
    Messages:
    156
    Gender:
    Male
    Location:
    Vancouver BC, Canada
    Hi @barrizqi, will you still work on the compatibility mod that intends to make both EE and FW functionable to the latest VP?
     
  10. droberts97470

    droberts97470 Warlord

    Joined:
    Aug 28, 2007
    Messages:
    170
    Location:
    Roseburg, Oregon
    I have deleted the game and reinstalled 3 times each time it repopulated the Mods folder with mods I used before I loaded the community patch. These mods are not listed as compatible with the community patch. The game keeps crashing. I have gone through and deleted each mod except for the 6 community patch mods. The game crashes after that too.

    It seams logical that with only the 6 community patch mods loaded that there should not be any compatibility issues so it should not crash.

    The patch loads lots of leaders that don't load in the basic game so I'm thinking I've got all of the leaders mentioned in the installation instructions.


    Does anyone have any ideas?
     
  11. Enginseer

    Enginseer Salientia of the Community Patch Supporter

    Joined:
    Nov 7, 2012
    Messages:
    3,228
    Gender:
    Male
    Location:
    Somewhere in California
    Well of course it would crash. You need all the default files that BNW had.
     
  12. droberts97470

    droberts97470 Warlord

    Joined:
    Aug 28, 2007
    Messages:
    170
    Location:
    Roseburg, Oregon
    Which files are those? BNW loads when I go to steam. It's one of the games on my list of games.

    I even deleted Steam. When I reinstalled steam the games I own just came back. So I ran the patch installer, opened up the game and the patch mods were there. I selected them and deselected all of the old mods, started a game and got well into it when it crashed. Over and over, different rulers, it made no difference, it crashes.

    I'm sure I'm doing something wrong. I just don't know what.
     
    Last edited: Aug 9, 2017
  13. Enginseer

    Enginseer Salientia of the Community Patch Supporter

    Joined:
    Nov 7, 2012
    Messages:
    3,228
    Gender:
    Male
    Location:
    Somewhere in California
    do you have all of them like all of the DLC?
     
  14. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,322
    Location:
    Czech Republic
    That's because you are subscribed to them on Steam Workshop. The safest way will be unsubscribing them. If you do not want to lose track of your favorite mods, "favorite" them before unsubscribing. Then delete everything in the mods folder and run the autoinstaller again.
     
  15. droberts97470

    droberts97470 Warlord

    Joined:
    Aug 28, 2007
    Messages:
    170
    Location:
    Roseburg, Oregon
    I don't know. Is there a list some where I can check?

    BTW. What dos DLC stand for?
     
  16. droberts97470

    droberts97470 Warlord

    Joined:
    Aug 28, 2007
    Messages:
    170
    Location:
    Roseburg, Oregon
    I'll give it a try.
     
  17. Enginseer

    Enginseer Salientia of the Community Patch Supporter

    Joined:
    Nov 7, 2012
    Messages:
    3,228
    Gender:
    Male
    Location:
    Somewhere in California
    (DownLoadable Content) When you buy Civ 5, did you buy the whole package?

    On an alternative note, did you subscribe to the Community Patch? I don't recommend subscribing to the Community Patch because of how outdated it is relative to CivFanatic's version.
     
  18. droberts97470

    droberts97470 Warlord

    Joined:
    Aug 28, 2007
    Messages:
    170
    Location:
    Roseburg, Oregon
    I bought the Civ V parts separately as they came out

    I didn't subscribe. I do have a copy of the Vox Pop file from July 23 that I used to reinstall the patch with. And to reinstall it.
     
  19. bhawk

    bhawk Chieftain

    Joined:
    Sep 9, 2015
    Messages:
    2
    Yo so if im just using the community patch and not CBP, then can I use the incompatible mods and the already "incorporated into CBP" mods?
     
  20. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,322
    Location:
    Czech Republic
    Yeah I think in 99% yes.
     

Share This Page