RevolutionDCM for BTS

Glider pretty much covered everything, but just wanted to clarify some things. 2.72 is mainly a bug fix release, and is save game compatible with 2.7; the current build, 2.8, on the SVN is not save game compatible. We mainly just wanted to release 2.72 as there were a few issues, such as BUG options not responding correctly, that had been fixed and kept save game compatibility. Version 2.8 is probably a long ways off, so if you're waiting for it, be prepared to wait a while, a couple of months is my best guess at this time; who knows though, things may change quite a bit. Also BBAI wasn't included because jdog wants to significantly tweak some AI behavior so the AI was more "aware" of revolutions and minor civs, and we just didn't want to delay the 2.72 build for that, as he doesn't know how long that'll take. So my advice would be not to wait for 2.8 if you have a mod that uses a RevDCM core; if you don't care about save game compatibility you may consider using the SVN, but I'd look at the TODO list and SVN changelog just to make sure the SVN is working right and has been updated (for instance right now the RevMP code hasn't been ported from 2.72 into 2.8 yet, that might take a couple days). And again, we have no idea when 2.8 will be released, but it's wise to assume it will take a while.
Forgive my lack of knowledge here. I've just compiled my DLL for my mod and when i start it up im getting errors with CivicInfos.xml and BuildingInfos.xml

1. (my text file wont load)
failed to find sibling

2. buildings/CIV4buildingsInfos.xml
Element 'PrereqGameOption' is used but not declared in DTD schema.

when i remove this one, iUnitPriceModifier gives same error on load.

3. GameInfo/CIV4CivicsInfo.xml
element 'bUpgradeAnywhere' is used but not declared in DTD /schema
line 73,22

When i remove this bAllowInquisitions pop the same error.
Have not touch these files.

They are declared in the schema that is in the folder. These were not present in 2.6, have not seen them before.
Hey, I've been getting some weird bugs with 2.72. At first, whenever I talked to an AI the portrait would come up, but there would be no diplomacy text. I reinstalled, which fixed that problem, but now I can't access the civics screen. Reinstalling didn't fix anything. Anyone know what's going on?

Yes the diplomacy screen stuffs up if you have more than one installation of RevolutionDCM present (Phungus correct me if I am wrong). Thanks for reporting the Civics screen issue.

Yep you are correct, a last minute typo occurred when cleaning up the civics screen for the case when the Revolutions mod is turned on. Wait about 15-30minutes and I will upload a new version 2.721 to fix the typo. Thanks for reporting it.

EDIT: Ok version 2.721 is up.
Although I cannot really help much with modding RevolutionDCM for other mods, in your case it looks like you have two independent issues. You have a DLL issue but also it appears your XML schemas are out of date for your mod. Here is what you absolutely must do when building a new mod.

1) First compile a RevolutionDCM DLL from the supplied sources and BTS 319 base sources.
2) Use that DLL to run RevolutionDCM vanilla
3) Check that the behaviour of your DLL matches identically to the RevolutionDCM DLL
4) Once confident that your RevDCM DLL has been compiled correctly you may modify the DLL for your own needs
5) When modifying XML, make sure that your modified schema's contain at least the same definitions as the base mod.

Im using RevDCM 2.721 to make a modification and have a question about civics. If I was to add and change civics would it cause any problems?
Eh Bobebrown
Should be fine. The civics screen has been altered to be able to accommodate large numbers of civics as per what you find in RoM (which is based on RevolutionDCM). Suggest that you experiment with adding a civic via WoC.

Eh Cripp
Do not know anything about Temudhins WBS loading modcomp.

Some leftover code from older installs conflicts with newer installs. It's something in I believe.

I doubt. I've deleted all older versions of RevDCM and CCV and still got trouble with the screen. :(
Eh Thomas
Could you post python error logs? Afforess and I assumed you have duplicated installs which produces this problem but maybe there is another issue. Are you playing straight RevDCM or a modified RevDCM would also be nice to know.
The newer version of BUG removed a few python files that it used to need. Leaving those older modified files around with the new BUG code RevDCM uses will cause conflicts; most noteably the Diplo screen will not have text. Fixing is simple, reinstall (reinstalling will ensure removall of old any old files left over from a previous installation, as RevDCM's installer automatically purges any old version of itself when installing - the first time the installer is run this does not occur though, as the installer does not know there is an old version there until it has been run once before).
Also this is about the dozenth time someone has brought this up.
Change. Sometimes change is a good thing. But sometimes it's worse. :mischief:

I know how to fix the diploscreen bug! The problem comes from new code in! Go back to the old code and so your out of trouble. :D

Here is the fixed file for RevDCM 2.721:
@Thomas SG

I can reproduce no bugs with diplomacy in neither RevDCM 2.72 nor RevDCM 2.8 from the SVN. Please ensure you have reinstalled RevDCM 2.72 using the installer so that the old version files have been removed (install twice in a row so that the the uninstaller is tripped); or if you are using the SVN 2.8 version, make sure you have deleted all old files when exporting to your mods folder.
Top Bottom