1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Workaround when returning to main menu with R&F and some mods 2018-02-10

Workaround for the game not loading and returning to main menu with R&F and some mods

  1. Gedemon
    • This is a quick fix for the following issue:
    When some mods (not all) are enabled, and when using the R&F ruleset (vanilla game is not affected), some (ie "random") DLC try to load their R&F compatibility file (like CivilizationName_Expansion1.xml) before the base data for the DLC is loaded, resulting in a DB lock because of missing references and sending the user back to main menu.

    The workaround is simply a few edited .modinfo replacing the game's files, to manually set a load order of "2" for the files updating the DLCs for Rise and Fall. (A load order of "1" works too and is used in some other versions of this fix)

    • IMPORTANT : this is not an universal fix, check your Modding.log before using it
    Activate all DLC, R&F and the mod you have the problem with, then launch a game, and after being sent back to the main menu, open Modding.log (see How to get the logs) with any text editor (like notepad) and search for "ERROR: Failed to release save point", it'll give you a file name above like this:
    Code:
    [1994494.475] UpdateDatabase - Loading Data/Poland_Jadwiga_Expansion1.xml
    [1994494.483] ERROR: Failed to release save point.
    Note that if ANY of the "ERROR: Failed to release save point." in the log doesn't reference a file like this one (Data/[DLC]_Expansion1.xml), the fix won't work, the problem needs to be fixed elsewhere first (it should point you to a mod)

    You can ignore the lines starting by "Warning", they are not relevant for the "return to main menu" issue, and Rise and Fall triggers a lot of those, even without any mods activated.

    • Installation (PC)
    1/ Download the attached fix.zip
    2/ Extract to \Steam\steamapps\common\Sid Meier's Civilization VI\DLC\ folder, replacing the existing files

    If you don't know the location of your Steam folder, you can go in "Your Library" on Steam, right click on Civilization VI then choose "properties", then "local files" then "browse local files"

    • Installation (Mac)
    • Uninstallation
    to uninstall the fix, simply Verify Integrity of Civilization game files on Steam

    • This fix won't help you when:
    - You have crashes to desktop
    - The modding.log points to an error that is not related to a DLC file

    • Other versions:
    There are other version of the fix with additional information that you may want to check:
    https://www.reddit.com/r/civ/comments/7x8l5g/civ_6_rise_fall_dlc_momentillustrations_database/
    https://www.dropbox.com/sh/1jt0bjpos5u18q5/AABOD2-HOBcU71m1BFksx59ga?dl=0

    • Credits:
    - Thanks to savio.dibi for testing, providing and editing the attached file.
    - Everyone on YnAMP thread for reports and tests
    poundjd, ravennaux, MadManCam and 2 others like this.

Recent Reviews

  1. Xoopa
    Xoopa
    5/5,
    Version: 2018-02-10
    This is nice, but i dont know if its working or not. It's only showing the error message for DLC's but it's not working for TSL earth map as i hoped it would. any thing im doing wrong?
  2. koza6x1
    koza6x1
    5/5,
    Version: 2018-02-10
    Generaly all is good. Recently game back to main menu but now I can start map and there is a new problem with city states. If I run game with CS after the next turn game crashed to desktop. But when I turn off all DLC or CS all is right. Where is the problem? :)
  3. FiremanDave
    FiremanDave
    5/5,
    Version: 2018-02-10
    Since R&F I was having epic problems with mods - I even unsubscribed from all I had, then only resubscribed to ones that had been proven working, but still no good! Tech support couldn't help. But this... brilliant!!! Thank you so damned much =D
  4. Elleseer77
    Elleseer77
    5/5,
    Version: 2018-02-10
    I didn't have crash to desktop before, after installing this happens all the time :(
    And before downloading I checked my log and it matched all your requirment :( now I'm having XML issues after downloading this
    1. Gedemon
      Author's Response
      xml warnings are present with the base R&F DLC.
      crash to desktop is another issue, not created by this.
  5. Harre
    Harre
    5/5,
    Version: 2018-02-10
    Well done! Now I'm able to run Rise and Fall on the earth
  6. BowWowTow
    BowWowTow
    5/5,
    Version: 2018-02-10
    Yea I'm getting the same problem as Jackdaw900 and Naterrama, it crashes after loading the game and it says the reason (in the modding log) has to do with loading the XML. Any fixes?
    1. Gedemon
      Author's Response
      the fix won't work for "crash to desktop", only for some of the "return to main menu" cases.
  7. Jackdaw900
    Jackdaw900
    5/5,
    Version: 2018-02-10
    thanks , but in my case , the error is not in the ""save point release", it is "Warning: LocalizedText - Error Loading XML". i still tried to replace the files in CIV IV/DLC/ folder. when i lauched the game, it didnt send me to the main menu. it was loading with sean bean indtroducing the Civ so i was full of hope, and then the game crashed and sent me directly to the desktop :(
  8. Naterrama
    Naterrama
    5/5,
    Version: 2018-02-10
    I am getting the same error as Jackdaw900.
  9. gelodgreat
    gelodgreat
    5/5,
    Version: 2018-02-10
    Thanks for this. I thought my mod wasn't working. But this fix it.