• Civilization 7 has been announced. For more info please check the forum here .

[LP] can't start new game w/o crash since rulers of sahara

fy00sh

Nonbinary | Peaceful Builder
Joined
Jun 24, 2020
Messages
750
even after disabling all my mods and validating all my files, my game continues to crash reliably midway thru the entering-game load screen. no idea what i can do to fix or even troubleshoot this anymore, any ideas? anyone else getting these issues? let me know what info i can provide to help figure this out

Spoiler crash log :

Unhandled Exception
Code: EXCEPTION_ACCESS_VIOLATION
Error reading address 0x140

Call Stack
-----------------------------------------------------
??? ! ??? ???, line 0
??? ! ??? ???, line 0
 
uninstalled and reinstalled and the issue seems to have persisted
 
pictured below: so sometimes when the game crashes, the part that looks like it's blacked out in the steam library actually just kinda slides down-left off screen leaving blackness behind it. this has only ever happened today and whenever it happens its after the game crashes. sometimes instead it closes discord, which then doesnt reopen properly and just hangs on an empty screen. the bug reporter messing up is new. no idea how the game is crashing so hard it impacts other applications.
1676605567204.png

pictured below: and heres what the loading screen looked like just before the crash. the dummy text thing has only happened twice before out of like 12 attempts at starting a game
edit: i should note that this game was the result of disabling all mods (theres a mod manager mod which didnt get disabled when i hit "disable all" but i figured it wouldnt matter), going to "create game" and immediately hitting "start game" without changing anything
20230216224448_1.jpg
 
My general advice is to first verify the integrity of your game files through Steam if you've not already done so.

If that doesn't work, next try deleting the Mods.sqlite file @ "...\Documents\My Games\Sid Meier's Civilization VI\Mods.sqlite" and the three debug files in "...\Documents\My Games\Sid Meier's Civilization VI\Cache".

If that still doesn't work, try uninstalling the game making sure to delete any leftover files/folders in "...\Documents\My Games\Sid Meier's Civilization VI" and "...\Steam\steamapps\common\Sid Meier's Civilization VI", and then do a fresh install.

And, finally if none of that works you can submit a support ticket to 2K/FXS here. They'll likely ask you to submit information like the diagdx, GraphicsOptions, and logs that can be found by following the instructions here.
 
My general advice is to first verify the integrity of your game files through Steam if you've not already done so.

If that doesn't work, next try deleting the Mods.sqlite file @ "...\Documents\My Games\Sid Meier's Civilization VI\Mods.sqlite" and the three debug files in "...\Documents\My Games\Sid Meier's Civilization VI\Cache".

If that still doesn't work, try uninstalling the game making sure to delete any leftover files/folders in "...\Documents\My Games\Sid Meier's Civilization VI" and "...\Steam\steamapps\common\Sid Meier's Civilization VI", and then do a fresh install.

And, finally if none of that works you can submit a support ticket to 2K/FXS here. They'll likely ask you to submit information like the diagdx, GraphicsOptions, and logs that can be found by following the instructions here.
thanks, will work on trying that out tomorrow. i did verify the file integrity pretty early on in all this and it said it found 17 files to fix (that was prolly mostly edits to jerseys and monopoly product names, plus file replacements for leugi's city styles mod), so i'll try rerunning that and deleting those other files first. heres hoping it works!
 
ok so i unsubbed from every single mod i have after putting them in a collection so i can easily reacquire them after all this, then reverified file integrity, then deleted the mods.sqlite and the cache files, and it still crashed upon trying to start a game. this time i got a new type of crash out of the firaxis bug reporter, ill include it below in case it's of any note.
Spoiler crash log from bug reporter :

Assert Failed

File: G:\BuildAgent\work\aeddd1dfc51ba22c\FireBug\firebugapps\Libs\CivTech\Platform\src\Windows\Platform_Memory.cpp
Line: 560
Expression: pBlock
Message:
Time: 2/17/2023 13:01:03



If that still doesn't work, try uninstalling the game making sure to delete any leftover files/folders in "...\Documents\My Games\Sid Meier's Civilization VI" and "...\Steam\steamapps\common\Sid Meier's Civilization VI", and then do a fresh install.
question about this step: will it delete my hall of fame records? id really like to keep those if at all possible. would it suffice to add the word "backup" to the end of the file names that say "Sid Meier's Civilization VI" so it says "Sid Meier's Civilization VI backup"? if i understand right that'd make those file locations go unused, right?
 
update: I GOT IT BACK FINALLY
AND i still have all the mods i really care about AND i kept my hall of fame
something about the second reinstall did it i guess? or maybe something in my old setting folders?
not sure what but THANK YOU SO MUCH
no more crashes \(^_^)/
 
Top Bottom