• Civilization 7 has been announced. For more info please check the forum here .

City center yield not added

SatanasOz

Chieftain
Joined
Oct 27, 2009
Messages
59
Location
Frankfurt, Germany
Hi,

I just noticed this straight forward bug in my first game. The city center tile food isn't added to the food calculations for Orleans. I don't know when it happened first, am going back in to check. Noticed it when I got the message that the city is starving.

It didn't change for the rest of the game. I am trying to find out what caused it, but it's hard to say. I fiddled a lot with the governors, maybe thats the cause. The city was conquered.

back in a sec ...
 

Attachments

  • CivBug.jpg
    CivBug.jpg
    325.9 KB · Views: 1,139
  • orlean_bug.Civ5Save
    819.6 KB · Views: 301
ok, I just dug a bit deeper

The problem is there right from the beginning - I have captured the city somewhere in the ancient era. Added another save where the city is still my puppet. It seams, the puppet has the same problem, the "time to pop" doesn't change when annexing.

Further, as far as I saw, it is the only city with this problem, especially the only one conquered.

One more thing I want to investigate later is if it has something to do with beeing the last city of Napoleon, meaning the city in witch I wiped him out. I am going to check a later save, where I have almost the same situation with ramses, maybe it is the same there.
 

Attachments

  • Bismark_cont_2.Civ5Save
    602.7 KB · Views: 211
last one for tonight:

no, it has nothing to do with conquering, but there was one more thing before I leave it to you. There is another city within 3 hex, overlapping. The other city shows the city tile as "unworked", but it is not possible to check it an work it from there.

I've tried to reconstruct this with my other 2 cities so close together, but no luck. There, everything works as supposed, the tiles are shown als "worked by another city" - you can not "take over" the city center tile from one city to another.

Thats it so far, if there are any questions, feel free, I have no idea what caused it :)


 

Attachments

  • CivBug2.jpg
    CivBug2.jpg
    141.5 KB · Views: 11,643
In my last game I saw the same thing, and it was a city given to me as part of peace treaty, and is within 3 tiles of another city. It seems that when a city is conquered the tile is somehow under a different city's authority, except you can't control that tile from either cities--the one built on the tile assumes that it is been worked, while the other city assumes that it does not have the right to change who works the tile in question.

Maybe recheck the placement of cities upon obtaining a new city?
 
I totally bet it has to do with cultural borders. Ever wonder why when you capture city A you get some squares but not all around it, those belonging to city B still have their own spots? Well, what if city B had a lot of culture and expanded into the square of city A, taking it over. You capture City A, but city B still controls that tile.

Quite possibly something like that.
 
I have seen this too in a city given to me by a surrendering enemy. I assume it had the problem whilst operating as a puppet since it shrank to size 1. After I annexed it, just to investigate, the city showed no production from the city square. I have a screenshot if needed.
 
You have 15 food (8 from the city tile; 4, 2, and 1 from the others). A pop 7 city consumes 2 food per citizen, leaving a surplus of +1. This is what is shown... Seems to be working as intended to me.
 
Okay, I have some screenshots now.

The circumstances about the city: I play Russia, been at war with Germany, who gave me half their empire as part of the peace treaty afterwards. This included the city Bonn, which is the only one I annexed. The city itself should give 5 food, 11 production, 2 gold (as it shows on Screenshot 2). Total production adds up to 8 from terrain (see Screenshot 1). Building the courthouse didn't change any of this.

Screenshot 1 (city view)
Spoiler :


Screenshot 2 (city view)
Spoiler :


Screenshot 3 (the surrounding area)
Spoiler :


The same game:
View attachment Yields.Civ5Save

I don't have the save from before the bug happened.

Moderator Action: Threads merged. The_J
 
You have 15 food (8 from the city tile; 4, 2, and 1 from the others). A pop 7 city consumes 2 food per citizen, leaving a surplus of +1. This is what is shown... Seems to be working as intended to me.

That is the wrong screenshot (or more the wrong city) - the topic is about Orleans, see the screen in the first post. The second post was just to show more weird behavior (The City center looks like it can be worked from this adjacent city, but can't)

Load the save, you'll see ;)
 
This happened to me today.

It was Japan's old capital, conquered by Aztecs, then surrendered to me in a peace treaty. This is on the Earth map, standard size, epic speed.

I'm thinking this might have been like this all game, because Japan never expanded well, and Kyoto never grew very well either.

Screenshot:
Spoiler :




The city center is producing 5 food, 2 production and 1 gold, none of it being used.
 
Same problem. Greece gave me Corinth and Sparta. I've since razed Sparta - it was in the same location that Pharsalos is now. At no time was Corinth within three tiles of any other city. I'm not getting any production from Corinth's central tile, nor am I getting any maritime bonus there.


View attachment Game.Civ5Save
 
Strange one this!

I was battering Elizabeth whilst playing Oda (why does that sound so wrong?), and she threw me a peace deal at an opportune moment which included two cities.

I took the deal, and noticed something was amiss when both cities starved down to 1 citizen. Thanks to the patch I was able to have a look what was going on and eventually worked out that the base city tile resources were not contributing to the cities output. (thus penalising them both 2 food, 2 prod & 1 gold)

Anyone seen this before? I find it very rare that civs offer up cities in deals so I don't know if its common. Its a large map on Immortal if that makes a difference.

PS as an aside, on this game the Republic / +1 Production in each city social policy seems to have had no affect on my cities...
 
Moderator Action: Threads merged.

Nice to see that you've joined us to help us (or more the devs) to fix this game.
This bug is already known, but don't hesitate to report others when you see them (but please take first a look at the confirmed bugs list ;)).
 
Hello,

I guess the following is a bug and I didn't find elsewhere, so I report it here:

In the attached save file the city of Vijayanagara (I hope I didn't misspell) in the middle of the map has 0 :c5production: Production even though it shows 6 :c5production: Production on the tile?! In all the other cities that I checked the :c5production: Production works just fine.

Misc Information: I have the policy "Merchant Navy", which gives additional 3 :c5production: Production. I use CiV version 1.0.0.621 and no mods.

Does anyone else have this problem?

Edit: The problem remains after the new patch version 1.0.1.135.
 

Attachments

  • Zero Production City.Civ5Save
    708.2 KB · Views: 194
Could you maybe take a look, if also food is not added (because that we would already know, see here).

Yes, seems to be the same bug. The entire city tile (including food, production, and gold) is ignored and I got the city via a peace treaty. It's further away than 3 tiles from another city, but I remember it being the last city in the list of cities I got after the peace treaty. I just noticed it because of the library taking forever to build...

But at least we know that the bug survived in version 1.0.1.135.
 
Yes, I just encountered this in a new game entirely post 12/15 patch. City center of the one city given to me in peace treaty (soon after conquering India's capital) gives no production (including food). Accepted city as puppet, annexed it 10 turns later and then discovered bug when it only had 1 production to build courthouse! City is 5 away from other cities.

Quite annoying to have it starving to death (slight exaggeration. though it did lose pop), even with a maritime ally!
 
Same problem for me.

City was given in peace treaty, the city center tile is X F (several maritime allies), 2P 1G and i get nothing of it...

Problem is especiallly for food and production. Will try to propose a save or a screenshot later...
 
Top Bottom