1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civilization III Fixes (PLEASE READ)

Discussion in 'Civ3 - Technical Support' started by sk0tie, Nov 1, 2001.

  1. roybjr

    roybjr Chieftain

    Joined:
    Jun 21, 2015
    Messages:
    1
    I have Civilization III Complete Edition version 1.22 I am running Windows 8.1 64 bit and I am trying to change the resolution to 1600x900 and have tried creating a conquests.ini file but nothing seems to work. Can anyone help me with this? Thank you. It is a download version not a STEAM version.
     
  2. Lord AJ

    Lord AJ The Quartermaster

    Joined:
    Jan 10, 2015
    Messages:
    436
    Location:
    In that Capital City Of Yours
    First of all, I don't think you need to create a Conquests.ini file. It should already be there. Next, you need to add keepRes=1 in that file and save it.
    Now the game will run at the native resolution of your monitor.
    Also note that the change in resolution is not noticeable on some screens in the game, for example, the start screen and the city view screen.
     
  3. tjs282

    tjs282 Socially isolated since 1975

    Joined:
    May 19, 2009
    Messages:
    2,818
    Gender:
    Male
    Location:
    ...just here for the job/ handouts/ woman
    If you've just created a text file (using e.g. the template available on CFC), you need to make sure it's saved as a .ini file-type -- if file-extensions are invisible, just putting '.ini' in the filename won't be enough: Civ3 will see it as 'conquests.ini[.txt]' and treat it as a simple text-file. That said, you don't really need to create an .ini file from scratch -- the game will do that the first time you run it, creating one .ini for each version of the game that you have:
    • the Vanilla1.29 Civ3.ini will be in the root ...\Civ3Complete\
    • the Conquests1.22 Conquests.ini will be in ...\Civ3Complete\Conquests\
    • the PtW1.27 Civ3X.ini -- if your installation includes a Civ3X.exe -- will be in ...\Civ3Complete\PtW\
    All you then need to do is add the necessary lines to it/them. If that's what you're trying to do, but it's still not working, the next question I'd ask is, where did you install the game? If it's in the default C:\ProgramFiles(x86)\... directory, then you may run into difficulties altering any gamefiles, because Windows treats everything in that directory as protected.

    As I understand it -- and bear in mind I'm not tech-savvy! -- if you don't have Admin privileges (and possibly even if you do), any changes you make to files in that directory don't actually get saved there, the 'new' files get saved in Windows' 'VirtualStore' instead. When you then run the game, because it's only searching for files within its own installation path, it doesn't 'see' the altered .ini file in VirtualStore, so uses the unaltered default version. (NB this VirtualStore problem may also apply to your savegames, and possibly also any additional files you try to push in there, e.g. graphics mods, etc.).

    If that's the case, you can spend time messing about with user-privilege settings, or you might be better off simply uninstalling and reinstalling in a non-protected location, e.g. create a directory called C:\Users\Public\Games\..., and (re)install there instead. (I chose the second option for my new Win8.1 box -- and I've also installed CivAssistII to that directory, so that it can locate savefiles easily). Once you've done that, you should be able to alter the .ini to your heart's content...

    As AJ says, you can get a 'widescreen' main-map view by adding 'KeepRes=1' to your .ini, but the unit-animations may end up looking very small. And since Civ3 was originally programmed for a 4:3 aspect ratio, all of the Advisor/Civilopedia screens will stay in their original 1024 x 768 size. You might also like to try adding 'VideoMode=1200', which will(/should!) use the full height of your monitor, but keep the game in a 4:3 display.

    If you want to have more dangerous Barbarians in Conquests, don't forget to add 'NoAIPatrol=0' to the Conquests .ini -- and I've also added 'PlayIntro=0' to skip the intro-movie.
     

Share This Page