Firaxis: FFS, support the game. Bad Memory Allocation error when SAVING games

Been a long time since I checked in here, due to...






wait for it....


















MAF frustration. I literally haven't even attempted to play the game since January or so because I couldn't finish a game. Sounds like the everything is pretty much same as it ever was.

I did read something in here about ViSa, so maybe I'll see if that mod has a way to address this nasty little gift from Firaxis. It really makes me wish that I wouldn't buy the next version of Civ, but I'm smart enough not to vow I won't buy it if they don't fix this, because I likely won't be able to keep myself from buying it...:blush:
 
Question about MAF: Is this what I got when I tried to save a game in Ancient Mediterranean and the save file ended up being 900 bytes or something puny like that and it crashed? It happened so long ago I don't remember the message.

But that's the only time it's happened for me. My system specs are pretty subpar for CivIV: NVidia GeForce MX440, 512 MB RAM (until recently). I've played Huge maps with 18 civs into the 1800s with no save problems, just it-takes-way-too-long problems. However, there is one setting I have an excess of:

Virtual Memory. I had about 1.25 GB when I started CivIV, and after receiving a few Out of Memory errors bumped it up to 2.5 GB, which I've yet to hit. Could VM have anything at all to do with it?

The only other setting I have out of the ordinary is XP Home Service Pack 1 instead of Service Pack 2. Not sure if SP2 could have anything to do with it, you wouldn't think so if 2K, ME, and Vista all can have MAFs.

Just my $0.02. I've been fortunate in this area relative to most.

Can't help pointing out the double-entendre, either. When I wrote 2K can have MAFs, I wasn't even thinking at that time how 2K is the company that made CivIV :lol:
 
But they aren't releasing their MAF fix standalone, which I think is a good reason to re-do their work. ;)

That MAF work-around is not our work, but an independent programmer who wishes to release it himself, not through the ViSa people.....sorry.
 
the MAF error: when you try to save a game, a dialog pops up saying, "Memory allocation failure - exiting program. Reason:bad allocation"

(the term MAF is short for "memory allocation failure").
 
At least I'm not the only one having this problem. Actually, I'm not sure if that's good or bad.

I'm running a dual core with 4gigs of ram, I should be able to play a game for five minutes without it crashing. It especially sucks because other than this error, warlords is the best game I've ever played.

I'll try the fixes that are out now, hopefully they'll work. If not, what a big waste of time and money. I was really getting in to liberating all of Latin America as Brazil. I've owned Civ I, II, III, and now IV, but if I can't get this working this will be the last Firaxis game I ever buy. :(
 
DVS420, it does not directly depends on your ram memory. check my signature for fix :)

Yes thank you bro, looking at that now. Keeping my fingers crossed.
 
Hmm.. i'll look at it too
 
This appears to be the most active and most recent of the MAF threads on CFC. Well, I've been having this problem for however long the game's been out. I don't necessarily have to play a mod to have it. It's just when the autosave kicks in, or when I save the gave (and that really sucks because at that point, the savegave file is completely eroded away into something like 90 bytes), or when I load up, at which point it really sucks because I have to load up the previous autosave or save in order to get past that point, if at all possible.

I've played this gave on two computers and both have experienced this problem. My previous computer had XP, and only had 128 mb of RAM (I tried upgrading the RAM and wound up pulling the plug on one of the chips without realizing it) a Pentium 4 processor and a video card too crapy to even upgrade. Anyway, believe it or not, it ran on the machine. But it CTD because of the MAF error. Duh, of course it did.

But now I sort of upgraded. I have a 2.6 GHz quad core processor, 3 gigs of RAM a NVDIA geForce 7000 series with 256 mb memory. Anyway, if I get saves over 2 gigs, I'm screwed. Though sometimes it happens at 1.5 gigs or less. Seriously, I know I can play a pretty darn good game before I'm screwed off my computer, but still, I play on some hefty mods, gigantic maps (that require a new size called "giant") and it only takes 5 or 6 saves before I get into those ranges. Not fun at all. I also am operating Vista, sure, Vista is the enemy. Not really, its actually the fact that XP and Vista use C++ programming which requires so much more memory to operate that in the end the OS and its subsidaries are taking up so much more of the memory that otherwise would go to the game that when the game requires a momentary spike in memory, it fails to acquire this, and crashes. That's my idea. Anyway, that's all.
 
Happens to me every save when my save file gets larger than 1400k, when I save (or auto save) the computer says fatal error, memory allocation error. I lose the save and the game shuts down. I play the huge earth 18civ mod. Everything legal, no pirates.

Stats:
HP Pavilion dv4 Notebook PC
Windows 7
Proc: AMD Turion II Dual-core Mobile M500
Graphics: AMD M880G w/ATI mobility Radeon HD 4200
Board: 3642 40.18
BIOS: F.03
RAM: 4GB DIMM DDR-2 800Mhz
HD: 298GB
 
Forgot to add: 64 bit

Increasing the virtual memory allocation to 10gb didnt help.

The bug ruins the whole game.
 
same here:
AMD Phenom Quad-core 2500 (x4) 64bit
NVidia 8800 GT (1gb of dedicated memory)
4gb Memory
Windows 7 64 bit

(recently upgraded to windows 7 in the hope it would fix the bug....)
 
I've just started getting this error message when playtesting the B5 mod for FF.

Error message on autosave

I run a windows XP(SP3) machine with 4GB of ram AMD Athlon 64 x2 Dual Core processor 5600+ 2.91Ghz. The file size of saves from previous turns is 130KB and i have plenty of space on my hard drive.

Does anyone know why i have just started getting this problem after years of playing?
 
Top Bottom