JFD's Sovereignty for VP

novelove0102

Chieftain
Joined
Jun 1, 2022
Messages
6
It's very interesting mod. I played it a few times and I could enjoy it very much.

IMO, Sovereignty is too low that Reform that can be passed is too limited until the Medieval Ages.
I think it is too difficult to satisfy the conditions of the Legitimacy, which is passed after the first Legislature is formed. (e.g +10% when all Cities have at least 8 Citizens, +5%/+10% when one/two other Legitimacies are met and 10% from city)

And there is some bugs.
(SUCCESSION) and (ELECTED) in (SUCCESSION) is not working.
(RECORDS) in (PUBLIC) is not working.(maybe)
(ASSIMILATION) in (CONQUESTS) is not working.
And all of refrom cooldown is not working.
 

Tonas1997

Chieftain
Joined
Apr 6, 2018
Messages
27
Getting this blank screen when starting a new game. I can't interact with anything :crazyeye:

screenshot.5320.jpg


EDIT: please ignore, I had JFD's Core utilities enabled. Leaving the post here for reference in case anyone else comes across the same issue!
 

Dimmy

Warlord
Joined
Oct 2, 2016
Messages
110
For compatibility purposes, should it be loaded after of before some other mods like More Wonders or 3/4UC? Or it doesn't matter?

Bravo for the big update, can't wait to start a new game to try this mod out.
 

Troll Warlord

Chieftain
Joined
Jul 13, 2022
Messages
15
For compatibility purposes, should it be loaded after of before some other mods like More Wonders or 3/4UC? Or it doesn't matter?

Bravo for the big update, can't wait to start a new game to try this mod out.
This mod references More Wonders and 4UC, hence it automatically loads after them, if those are present.

Regarding all other modmods I don't think there would be much compatibility issues after the removal of Wonders. But I'd prefer it loaded later anyway.

The only severe compatibility problems would be with mods that change VPs EUI NotificationPanel.lua
 

th3f00l

Chieftain
Joined
Dec 5, 2019
Messages
36
Forget it, I solved, maybe was an incompatible mod. One question, it is normal to have infinite pass reforms?
 

Troll Warlord

Chieftain
Joined
Jul 13, 2022
Messages
15
Forget it, I solved, maybe was an incompatible mod. One question, it is normal to have infinite pass reforms?
Check out latest file in the OP post. There was a version previously with enabled debug utils.
No need to start new game.
 

YakoTenma

Chieftain
Joined
Sep 23, 2022
Messages
1
I've got a problem with the mod. I have vox 2.6 and sovrg v13, once i hit pops 6 i can't form a goverment, i click on it nothing happens. halp
I have only vox and sovrg mods acctive.
 
Joined
Jul 23, 2022
Messages
130
I think you should upload screenshot and savegame file before and when it happens, just last few saves in order to author to help you. :)
 

STEPHEN HOFFMANN

Chieftain
Joined
Feb 19, 2021
Messages
32
Interesting mod. I'm slowly figuring out things as I go. A guide would be awesome to help out. In the meantime, a few questions:

1) I got to pop 18 and selected a government. When can I chose to go to another government?
2) If I move a reform back to the center, does that take down revolutionary influence?
3) What are the power cycles?
 

notaspambot

Warlord
Joined
Nov 1, 2020
Messages
197
Could the government change dialog be made dismissable or allow picking the same government when it's due to non-revolutionary sources? It can feel somewhat bad to be forced off your preferred government because you happened to hit some arbitrary threshold.

The Papacy government has a text issue with its faction descriptions. All of the cardinal factions state that they support economic reforms.

Interesting mod. I'm slowly figuring out things as I go. A guide would be awesome to help out. In the meantime, a few questions:

1) I got to pop 18 and selected a government. When can I chose to go to another government?
2) If I move a reform back to the center, does that take down revolutionary influence?
3) What are the power cycles?

Not the developer, but:
1) Have a revolutionary faction as a dominant faction, Population thresholds (6/18), Ideology unlock, Certain wonders
2) Yes
 

STEPHEN HOFFMANN

Chieftain
Joined
Feb 19, 2021
Messages
32
Could the government change dialog be made dismissable or allow picking the same government when it's due to non-revolutionary sources? It can feel somewhat bad to be forced off your preferred government because you happened to hit some arbitrary threshold.

The Papacy government has a text issue with its faction descriptions. All of the cardinal factions state that they support economic reforms.



Not the developer, but:
1) Have a revolutionary faction as a dominant faction, Population thresholds (6/18), Ideology unlock, Certain wonders
2) Yes
Thanks, I probably would have put more thought into my government choice if I knew it was going to be a bit. Although I'm putting a lot of seriousness into this game, waiting for the next version to come out.
 
Joined
Jul 23, 2022
Messages
130
Do we need a new version or is it playable with October first VP?

Also does AI uses all the new futures of the mod, or is it only more power fir the player?
 

Troll Warlord

Chieftain
Joined
Jul 13, 2022
Messages
15
One bug: Bonded (Labour) in industry reforms also remove 1 movement for gun/melee units, not only workers :)
Thanks! Fixed for the next version.
Interesting mod. I'm slowly figuring out things as I go. A guide would be awesome to help out. In the meantime, a few questions:

1) I got to pop 18 and selected a government. When can I chose to go to another government?
2) If I move a reform back to the center, does that take down revolutionary influence?
3) What are the power cycles?
1) Government choice is available at: 6 population, 18 population, Ideology change, Dominant Revolutionaries, Unique Government Wonder has been built
2) Yes
3) That are the remainings of another modmod from JFD (Cycles of Power), which is not compatible with this version of Sovereignty. I should remove all mentions of it from UI.
Does it work with the new version or require an update?

Does AI uses all new features or is it only more power to the player?
1) Yes, it works with the newest (2.7.1) version.
2) AI uses all the features (Governments, Reforms, etc) based on flavours defined in "Sovereignty_Flavours.sql", "Sovereignty_Leaders.sql" and "Sovereignty_ReformBranches.sql".
 
Last edited:
Top Bottom