[GS] Making a Custom Tech Tree Mod with no hanging technologies and when I click on techs near the end it causes a massive lag spike.


Jan 3, 2017
I recently got back into Civ 6 and wanted to make a mod which would implement a custom tech tree.

Everything seems fine until I finished clicked on the end of the tech tree and my game paused for a good 30 seconds.

I narrowed down the issue to Techs in the atomic era which had 61+ prerequisites to research.
At 60 prerequisites there was no noticeable delay between changing what tech I was researching.
At 61 prerequisites there was a massive lag spike.

I played around with different techs and different prerequisites but the only difference I could identify that could have possibly caused lag spikes was that the 2 technologies that caused a spike, had themselves 2 prerequisites techs.
This does not makes much sense as I have some techs with 5 different prerequisites at earlier points in the tech tree.

I also tried removing an earlier prerequisite, which would reduce the number of tech prerequisites to 4 and the tech tree from that point onwards went back to normal and I could swap tech path without issue.

I assume this has something to do with how the total number of prerequisites needed for a tech, I would not normally think this too much of an issue but it seemed to also lag when choosing a single tech to research past that point in the game.

If anyone has any recommendations on this subject or ideas on how I could debug this issues that would be greatly appreciated.

Link to download the mod if anyone is interested.
Sorry if this is a duplicate thread I tried searching but couldn't find the relevant terms.


  • NewTechTree.zip
    4.7 KB · Views: 4
Top Bottom