1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

[TSL] Yet (not) Another Earth Maps Pack

Discussion in 'Civ5 - Custom maps' started by Gedemon, Nov 8, 2010.

  1. orgrinrt

    orgrinrt Chieftain

    Joined:
    Nov 7, 2016
    Messages:
    64
    Location:
    Finland
    Hello everyone. This is my first post here after lurking around for a while, so forgive me if I'm doing something wrong. Just thought I'd share a solution to a bug/glitch I was getting after re-installing most of my mods to civ v.

    The problem was that the ynaemp setup screen was completely broken. Fields, droplists and basically everything was either missing or shown blank. I can't provide a screenshot of the view since I already fixed it and basically can't be arsed to rework my way to it being glitched just to grab a pic, sorry. But anyone with the same problem will definitely recognize what I'm talking about just by that description.

    The solution is rather simple, but curious. I had worked my way to a pretty huge combo of mods that were working together via trial-and-error, and the combo was working perfectly for a long time. Some days ago I decided to update some of the mods, and basically also re-installed all my steam workshop mods, since that's easy. But something started to glitch the ynaemp setup screen, and I spent more time than I'm comfortable admitting on trying to fix it. I started disabling mods one-by-one, and surprisingly it turned out that JFD's exce was the one glitching the screen. I did not expect that, and it was one of the last mods I was disabling, since from the day one of my mod-installs the JFD mods were almost completely working together with ynaemp and the community patch bundle.

    So, the fix: I updated the exce from v18 to v20 and it seems to be working, at least the setup page.

    TL;DR: If someone happens to have the yanemp setup screen glitching out completely, check if your exce is still in version v18. Somehow it interferes with it.

    OR

    If you have a bunch of mods, maybe installing the advanced setup screen mod will help you too (refer to the edits on this post). For me, that seemed to fix the glitching problem with every mod I have. Updating exce only fixed it with nothing else enabled other than ynaemp, community patch bundle and exce itself.

    I'm sorry that I can't provide any logs or anything of that sort. I'm not very tech-savvy myself, and don't know anything about any of those things. I just thought I'd share this since I was completely unable to play with mods because of this for a while, and thought it'd be nice if nobody else would have to go through that trial-by-error type of hunt for the problem.

    Hopefully this helps someone!

    EDIT: Nope, something else started messing the setup screen now that I'm re-enabling all my mods after I disabled them to find the problem. Seems like updating exce wasn't the complete solution, just fixed it with nothing else enabled but ynaemp, community patch bundle and the exce itself...... I don't get this. Seems like every mod I re-enable breaks the setups screen.

    EDIT2: Wow, this is getting weirder by the minute. Continued re-enabling some of the mods after the earlier problemhunt, and realized this: All the mods do work with ynaemp now after re-downloading and enabling a mod I stopped using when I got addicted to ynaemp: The advanced setup menu mod. Somehow with that mod enabled everything in the ynaemp setup menu seems to be working again with any mods on... Now I don't know if this was implied somewhere in the thread (it's 112 pages... too tedious of a read), but I feel stupid right now. Please do forgive me if this is common knowledge.

    EDIT3: Allright, so I've started a couple of perfectly working games with different conditions and bunches of mods on, and everything is now working 100%.

    The setup screen glitch was completely eliminated (for me at least) by 1) updating exce and 2) installing a mod called advanced setup screen. I do not know why exactly this solves the problem, but I'm a simple man: if it works, it works. Maybe someone more knowledgeable than me can figure out why this exactly is, or what caused the glitch in the first place. Or maybe it's already figured out somewhere buried in this thread... if that's the case, I'm sorry for doing a duplicate post of sorts.

    EDIT4: By the way, if someone is curious as to what kind of bunch of mods I've got working for me, here's a list of the mods that are working together seamlessly (in case someone's thinking of getting a mod but can't find any info on whether or not it's compatible with ynaemp (and community patch)). I guess somebody could benefit from all the trial-and-error I've gone through, so maybe it'll make someone's life easier.

    Spoiler :


    Unique Cultural Influence (v.4)
    Terrain Names Corrected (v.2)
    Landmines for BNW (v.3)
    Quick Turns (v.10)
    Ressource - Mint Include Copper (v.2)
    Industrial Building Pack (v.2)
    [BNW] Colonialist Legacies - Nigeria (v.3)
    Promotions - Expansion Pack (v.9)
    Religion - Improved Customization (v.15)
    (3UC) - 3rd Unique Component (v.7)
    National Wonder Collection (v.3)
    The Buccaneers (v.1)
    [BNW] Colonialist Legacies - South Africa (v.1)
    MC's Tibetan Civilization (v.3)
    [BNW] Senshi's Siberian Civilizations (Evenks and Nenets) (v.3)
    Enhanced Military Buildings (v.2)
    Community Patch Mod Compatibility (v.14)
    Militia Defense (v.14)
    [BNW] Colonialist Legacies - Kulin (v.1)
    JFD's The Kingdom of Bohemia (v.3)
    JFD's The Confederation of Switzerland (v.5)
    Harappa - Indus Valley (Brave New World) (v.52)
    MC's Oman Civilisation (v.3)
    (6a) Community Balance Overhaul - Compatibility Files (EUI) (v.1)
    Useful Oil Mod (v.10)
    JFD's The Commonwealth of Iceland (v.2)
    JFD's The Russian Federation (v.1)
    [BNW] Colonialist Legacies - Phillipine Republic (v.3)
    MC's Serbia (v.3)
    Krakatoa Fix (v.100)
    JFD's The United States of America (Lincoln) (v.2)
    JFD's Cultural Diversity (Core) (v.11)
    JFD's The Kingdom of Italy (Mussolini) (v.4)
    MC's New Zealand (v.2)
    [BNW] Colonialist Legacies - Malaysia (v.3)
    Krajzen's Buff - Ballista (v.1)
    Yet (not) Another Earth Maps Pack (v.24)
    MC's Thrace (v.2)
    Religion - Early Piety (v.1)
    JFD's The Soviet Union (Lenin) (v.3)
    JFD's The Kingdom of Belgium (v.1)
    MC and LITE's Nubia (v.3)
    Sukritact's Burmese Civilization (v.2)
    Reforestation (v.8)
    Global Relations (v.7)
    Ynaemp Leaders for City States (v.4)
    Improved Water Mill (v.1)
    MC and LITE's Moorish Civilisation (v.3)
    JFD's The Grand Duchy of Lithuania (v.4)
    Sukritact's Chinookan Civilization (v.2)
    [BNW] Colonialist Legacies - Mexican Republic (v.1)
    Favorite Religion Randomizer (v.3)
    Lake Victoria Fix (v.2)
    JFD's The United States of America (Roosevelt) (v.4)
    Lancers to cavalry (v.1)
    Historical Religions Complete (BNW or GK) (v.45)
    Sukritact's Zimbabwean Civilization (v.3)
    Terrain - Kasbah Extension (v.3)
    Stone Works In Plains (v.1)
    Terrain - Tipi (v.5)
    JFD's Exploration Continued Expanded (v.20)
    Cultural Capitals (Brave New World Edition) (v.16)
    Kongo (Brave New World) (v.48)
    JFD's The United Kingdoms of Sweden-Norway (v.1)
    Hypereon's Republic of Finland (Urho Kekkonen) (v.1)
    JFD's The Kingdom of Two Sicilies (v.1)
    JFD's The Empire of Great Britain (v.4)
    YnAEMP only Europe CS for BNW (v.1)
    Xia - Erlitou (Brave New World) (v.63)
    Terrain - Feitoria Extension (v.3)
    The Garamantes (Brave New World) (v.69)
    MC's Polynesian Civilisation Pack (v.3)
    Terrain - Poor Tiles Tweak (v.2)
    Wondrous Nature (v.2)
    Hoplite Mod (v.100)
    Sukritact's Sami Civilization (v.3)
    JFD's The United Kingdom of Great Britain and Northern Ireland (v.5)
    Ancient Building Pack (v.2)
    [BNW] Colonialist Legacies - Vietnam ft. Trung Sisters (v.1)
    Keldur Hall (Tundra Petra) (v.1)
    Sumer (BNW or GK) (v.70)
    [BNW] Colonialist Legacies - Cuba (v.1)
    Terrain - Polder Extension (v.3)
    Ethnic Units (v.31)
    Units - Airship and Land Ironclad (v.3)
    (2) Community Balance Overhaul (v.13)
    [BNW] Colonialist Legacies - Canadian Dominion (v.2)
    JFD's Event Compendium (v.4)
    R.E.D. Modpack (v.27)
    MC and GE's Romania (v.3)
    Atlatlist Mod (v.111)
    Solar Plant Fix (v.1)
    Shang (Brave New World) (v.21)
    (BNW) Leugi's Cuban Civilization (v.5)
    JFD's The Empire of Afghanistan (v.1)
    MC's Slavs (v.2)
    Religion - No AI Free Pottery (v.1)
    Mexican Civilization (v.3)
    Better Swedish City Names (v.6)
    Improved Windmill (v.1)
    Ancient Building Pack 2 (v.2)
    JFD's and Pouakai's Mercenaries (v.6)
    JFD's The Kingdom of Francia (v.6)
    The Olmec (Brave New World) (v.25)
    Cities of Marble (BNW) (v.6)
    JFD's The Kingdom of Egypt (Hatshepsut) (v.2)
    Rebalanced warfare (v.2)
    Gran Colombia Civilization (v.2)
    JFD's The Empire of Sweden (Karl XII) (v.2)
    MC's Scotland (v.3)
    JFD's The Kingdom of Bavaria (v.2)
    JFD's The Kingdom of Portugal (v.1)
    Custom Advanced Setup Screen (v.5)
    Great Admiral Aquaculture (v.1)
    Improved Caravansary (v.3)
    Medieval and Renaissance Building Pack (v.1)
    [BNW] Colonialist Legacies - Kimberley Aboriginals (v.2)
    Gibraltar and Reef Optimizations (v.101)
    Ynaemp City States for BNW (v.1)
    Terrain - Pontoon Bridge (v.3)
    Strategic Buildings Pack (v.2)
    Hypereon's Finland (Mannerheim) (v.4)
    Ayyubid Civilization (v.2)
    Neolithic Wonders (v.1)
    JFD's The Kingdom of Armenia (v.3)
    JFD's The Empire of Germany (Hitler) (v.9)
    JFD's The Papal States (v.10)
    (5) More Luxuries - CBO Edition (5-14b) (v.155)
    Civ Names by Policies (v.8)
    [BNW] Colonialist Legacies (and Senshi) - Samoa (v.1)
    JFD's The Empire of Spain (Philip II) (v.1)
    Sukritact's Phoenician Civilization (v.2)
    JFD's The Duchy of Milan (v.3)
    [BNW] Colonialist Legacies - The Cree (v.4)
    JFD's The Kingdom of Norway (v.6)
    (4) C4DF - CBP (v.11)
    Separate Great People Counters (v.3)
    JFD's Cultural Diversity (Soundtrack) (v.1)
    Resource - Granary Includes Bison (v.3)
    Enlightenment Era (v.6)
    (1) Community Patch (v.88)
    Mali (Brave New World) (v.52)
    MC's Greek Civilisation Split (v.1)
    Chop Jungle grants Production (v.2)
    The Sioux (Brave New World) (v.31)
    JFD's The Merchant Republic of Novgorod (v.2)
    JFD's The Kingdom of Egypt (Djoser) (v.1)
    Terrain - Motte-and-bailey Fort (v.5)
    [BNW] Colonialist Legacies - The Inuit (v.3) (v.2)
    JFD's The County of Flanders (v.1)
    JFD's The Empire of Japan (Tojo) (v.3)
    JFD's The Dominion of New Zealand (v.1)
    [BNW] Confederate States of America (v.1)
    MC's Mercia (v.1)
    Cistern and Marina - New Buildings (v.2)
    JFD's The Soviet Union (Stalin) (v.13)
    Units - No Futuristic Units (v.1)
    JFD's The United States (Teddy Roosevelt) (v.2)
    Natural Wonders Fix (v.1)
    (3) City-State Diplomacy Mod for CBP (v.27)
    (7) Community Events (v.3)
    Units - Throwing Axeman (v.4)
    [BNW] Bhutanese Kingdom (v.1)
    MC's India Civilization Pack (v.4)
    Religion - Beliefs Expansion Pack (v.26)
    African Forest Elephant Fix (v.100)
    JFD's The Kingdom of Scotland (v.2)
    MC's Ashanti Civilisation (v.2)
    Kievan Rus' (Brave New World) (v.74)
    JFD's The Nri Kingdom (v.1)

     
    Last edited: Nov 12, 2016
  2. Civ Spies&Lies

    Civ Spies&Lies Chieftain

    Joined:
    Dec 5, 2016
    Messages:
    19
    Pardon my mod inexperience. Civ V is pretty much the first game I've played with more than a mod or two.

    I play YnAEMP Europe Large (Dieters I think it's called. All my pc can handle late game.) It works great. After understanding fixes I needed to make, I get every Civ in the right place and even the City States.

    What I've been unable to do is get a decent number of City States.

    The default cap on the setup screen is 24. The best I have ever gotten (after hours of reloads) is 14. This worked ok but the lack of resources on the British Isle on that particular map start suffocated me. (happens w/this map. Just not enough land for random luck to bless England but so much. And going abundant doesn't change the gap, just makes everybody have "more" but at the same rough ratios.)

    My understanding comes from these posts:

    [TSL] Yet (not) Another Earth Maps Pack

    and

    The True Starting Locations of the Civs always win out so Venice eats up 3 of the options if they end up in game so I leave them out.. And I've worked through the other ones that can conflict and will fix the CStats that overlap.

    The only thing missing is the ability to remove the option for the game to chose a City State that can't be placed, thus deleting it which removes the chance at that # of City States appearing. When your luck is really good, you get about 12. Often it is single digits. And you almost never see more than one religious CS.

    Want desperately to learn/experience the diplomacy game but so few CS makes it sort of bearish. Any help or pointing in the proper direction would be greatly appreciated.

    *edit* I had found this before:

    https://steamcommunity.com/sharedfiles/filedetails/?id=158662453

    I have never been able to get it to work with even just YNAEMP. I use CBP mods so I figured I was that much further away from my goal. Maybe it's a helpful start for someone though.
     
    Last edited: Dec 10, 2016
  3. Jarula

    Jarula King

    Joined:
    Oct 22, 2016
    Messages:
    680
    Gender:
    Male
    I've tried numerous times to input a custom start position for a few custom mods (they both wind up continuously starting in Australia (is there any chance that they are being placed as random and the whole thing is being ignored and or do you need to input a requested resource?
     
  4. Lordie_Staven

    Lordie_Staven Chieftain

    Joined:
    Dec 28, 2016
    Messages:
    1
    Gender:
    Male
    Hi, like some others, I've been trying to use YNAEMP v24, using the Giant Earth Map, using a mixture of modded and vanilla Civs, and a recurring issue I have is that only the Shoshone appear in the selection menu for TSL only. I noticed that they are at the bottom of the list of starting positions in the resource file, I am unsure of if this is a coincidence. A reddit was opened on this, I couldn't see a solution there. I will send the log shortly, if necessary.
     
  5. Ankorafeonix

    Ankorafeonix Chieftain

    Joined:
    Aug 15, 2013
    Messages:
    75
    Hi, is this mod still being maintained? I have a similar problem to above - in the YNAEMP custom game screen, none of the normal game civs are available, only some of the modded ones. Not even all of the modded civs are available.

    I've spent hours digging around in the mod files trying to understand why the civs aren't showing up but it doesn't make any sense. I've also tried using v23 instead, and the civs work on that one, but now I get crash to desktop loading certain maps like Huge Earth.

    Edit: I discovered that disabling the Vox Populi mod caused the Huge and Giant maps to start working again. I wonder how Vox Populi could trigger desktop crashes in specific Ynaemp maps?
     
    Last edited: Feb 2, 2017
  6. Klisz

    Klisz King

    Joined:
    Aug 18, 2014
    Messages:
    804
    Database and Lua logs will indeed be needed (be sure to enable logging if you haven't yet!) as well as a list of all other mods you're using - I strongly suspect it's a mod conflict (probably with some recently-released civ since this issue has popped up so much lately).
     
    Lordie_Staven likes this.
  7. Estebanium

    Estebanium Prince

    Joined:
    Oct 16, 2014
    Messages:
    483
    Gender:
    Male
    Location:
    Germany
    The issue can be related to one of your custom civs. I had this problem in the past, too. Just start with only Vox Populi and YnAEMP, try to create a custom game and go back if it works. Then add another mod. Then start it again. You will come to a point at which it will not work anymore. Please delete your cache, ModUserData and logs folder before you begin.
     
    Lordie_Staven likes this.
  8. Charos

    Charos Chieftain

    Joined:
    Sep 17, 2015
    Messages:
    88
    Danmachsch, did you ever post that Imgur album of the new maps? I've been trying to find an album of everything included in YNAEMP (since the OP only has a small fraction of the maps) and I can't seem to find anything even close to comprehensive. A visual guide to the maps would be extremely helpful.
     
  9. Danmacsch

    Danmacsch Geheimekabinetsminister

    Joined:
    Jan 14, 2014
    Messages:
    1,316
    Location:
    Copenhagen, Denmark
    I think I did.. somewhere at least.. Let me see if I can find it again.

    EDIT: Found it! Not sure it's actually up to date, but hopefully you can use it.
     
  10. Charos

    Charos Chieftain

    Joined:
    Sep 17, 2015
    Messages:
    88
    Thanks a ton! This is perfect. All I really need is to get a general idea of the landmass sizes and map borders so I can pick which map fits my desired playthrough.
     
  11. Taco Bell Man

    Taco Bell Man Chieftain

    Joined:
    Apr 12, 2016
    Messages:
    17
    Hi JFD,
    I am having a problem with the use of YNAEMP v.24. For some reason, anytime I am playing on a map, the TLS does not work. If I put the placement with TLS and Random, only civilizations appear that use the TLS. For example, if I wanna against Germany on the North America map, Germany won't appear. Could you help fix this problem?
    Spoiler MODS :

    (1) Community Patch
    (1b) 43 Civs CP
    46926-historical_religions_complete__bnw_or_gk___v_45
    Enlightenment Era (v 6)
    Ingame Editor (v 39)
    JFD's Cities in Development (v 58)
    JFD's Cultural Diversity (Core) (v 13)
    JFD's Exploration Continued Expanded (v 20)
    JFD's Rise to Power (v 33)
    More Luxuries (v 155)
    Sukritacts Events and Decisions (v 3)
    Unique Cultural Influence (v 4)
    Yet (not) Another Earth Maps Pack (v 24)
     
  12. SLGray

    SLGray King

    Joined:
    May 18, 2015
    Messages:
    954
    Gender:
    Male
    Location:
    United Sates
    Sorry if this been asked before, but why does Denmark start between Sweden and Norway? Should it not start on the peninsula above where Germany is? I am talking about the first giant Earth map.
     
  13. SLGray

    SLGray King

    Joined:
    May 18, 2015
    Messages:
    954
    Gender:
    Male
    Location:
    United Sates
    Post Removed

    I fixed the issue I was having.
     
    Last edited: Apr 2, 2017
  14. dilophosaur

    dilophosaur Prince

    Joined:
    Dec 9, 2013
    Messages:
    506
    Germany in North America? Its starting location is in Europe, so it is obvious that there's no Germany in NA map.
     
  15. Malathorien

    Malathorien Chieftain

    Joined:
    Feb 2, 2014
    Messages:
    2
    Question:
    Guys, how would I go about editing the LUA to COMPLETELY PREVENT YNAEMP from spawning any resources? Please let me know if you can help ;p

    More info:
    I want it to correctly place all of the civs and city states but let me do all of the resources manually using IGE. I use CBP and the resource placements are just completely wrong, with tobacco and tea in England etc.
     
  16. Danmacsch

    Danmacsch Geheimekabinetsminister

    Joined:
    Jan 14, 2014
    Messages:
    1,316
    Location:
    Copenhagen, Denmark
    Always provide logs! Also, try clearing your cache and try again with only that one mod enabled. Sometimes hitting the reset button at the buttom of the screen works as well.
     
  17. Hardstyle

    Hardstyle Chieftain

    Joined:
    Mar 14, 2013
    Messages:
    20
    Welp, I cleared my cache , launched the game without any other mod but the tsl is still completly random and city state still spawn even when i set their number to 0. I just updated to the last version of this mod, the v22 was working fine.
    I might try to get the log if it can help.
    Thx for the quick answer tho :^)
     
  18. Aldebaran1997

    Aldebaran1997 Prince

    Joined:
    Mar 13, 2016
    Messages:
    512
    Gender:
    Male
    Location:
    Cheonan, South Korea
    Is this mod compatible with RAS? I assume not, but make sure.
     
  19. Chrisy15

    Chrisy15 Flower, Beautiful

    Joined:
    Jul 9, 2015
    Messages:
    2,079
    I doubt it will be; you'll either get an error or you'll simply get no effect from RAS.
     
    Aldebaran1997 likes this.
  20. AW Arcaeca

    AW Arcaeca Deus Vult

    Joined:
    Mar 10, 2013
    Messages:
    2,969
    Gender:
    Male
    Location:
    Operation Padlock ground zero
    Heeeeyyyyyy

    So does anyone have a list of which maps are linked to which database tables for v24? There's 48 maps and only 11 database tables as listed in XML\YnaempTables.xml, and the names aren't even consistent with the names of the .Civ5Map files. This is the main thing I could never figure out about adding YnAEMP support.
     

Share This Page