1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

[Wine] Civ4 in Wine 1.1.25 on Ubuntu 9.04

Discussion in 'Civ4 - Technical Support' started by damunzy, Jul 11, 2009.

  1. whsgis

    whsgis Chieftain

    Joined:
    Jun 26, 2012
    Messages:
    17
    As soon as I discover calendar my map goes blank. I am running C4 through Wine on Ubuntu 13.04.

    Any advice?

    Steve
     
  2. IPEX-731BA5DD06

    IPEX-731BA5DD06 Chieftain

    Joined:
    Dec 15, 2005
    Messages:
    2,472
    Location:
    Melbourne, Victoria, Australia
    Last edited: Oct 5, 2016
  3. LzPrst

    LzPrst Chieftain

    Joined:
    Mar 2, 2001
    Messages:
    96
    Gender:
    Male
    Location:
    the far west of middleearth
    I've been trying to make BtS run on a new ubuntu install 14.04. It's been hell.
    Any chance of helping me out? A few quick questions that might change the equation real fast.

    0. The real goal is actually to run the damned thing as a pitboss server for civ4, so running the game itself is not actually necessary, but that also seems to fail. I can start the server, but when I choose connection method (Direct IP/LAN/Internet) the program freezes. Any suggestions?

    1. I'm running it on a really old comp so the first thing I did was swap to xubuntu desktop manager, does it have the OpenGL drivers I need? Does pitboss need any graphics at all?

    2. My issues may also be caused by the ancient gpu (Intel 845), will it run civ4? Will it run OpenGL beyond 1.3?

    3. I've copied the civ4 folder to .wine/drive_c/Program\ Files/civ4, but this seems to have been a long route instead of a shortcut, any way to make this work?

    4. How can I get a hold of the error messages when BtS crashes so hard it locks up the recovery window so I can't save the logs :p

    Any answers or suggestions would be much appreciated.
     
  4. Pangaea

    Pangaea Rock N Roller

    Joined:
    Sep 17, 2010
    Messages:
    4,489
    Got a new taste for linux the last few weeks and am now running Linux Mint 17.1 Cinnamon (which is based on Ubuntu 14.04 LTS). Yesterday I managed to get the game running, and it runs quite well to be honest - most of the time. I installed it with PlayOnLinux, using the script. Then opened the patches as an exe within the virtual drive, and they all installed without a hitch. Even got BUG and BULL working now. However, there is an odd issue, sometimes, but not always, the map is pitch black. It looks like below. Do you know what is causing this and how I can fix it?

    The strange thing is that it sometimes works, and I can play, but when it ends up like this with the map black and parts of the UI missing, I need to try again. It seems to be enough to go back to the main menu and try from there, without having to restart the game.

    Edit:
    Never mind, I seem to have figured it out :) According to the script, it installs MSXML3, but something isn't right somewhere. According to this page the native version isn't complete, which I can vouch for. msxml3.dll file inside the virtual directory was 130kb, and after installing it via "add component" in PlayOnLinux, the file is 1MB. I read there were also problems with wonders/techs that centre the world map - Stonehenge and Math, so I tried a test game where I got Stonehenge the next turn. With the addition to the setup Stonehenge was built without issues, and all games I started went okay. When I removed it again, the map turned black when Stonehenge was built, and several new games I started were borked again. Turn msxml3 back to native via the install, and it works again. So this seems to be the solution.

    I've not played long games yet, but right now everything seems to work perfectly :thumbsup:

    LzPrst: I don't play MP games so can't really help you there. If you have an old computer that might be an issue, but then again, the game itself is old, so perhaps that isn't it. I did read somewhere there were problems with MP, but that post was 3-4 years old so may no longer apply. Since I've now got single player working very well, I'd recommend to try the install script via Playonlinux. It's basically a front-end for wine, but with much easier management of virtual drives and wine versions. You can use a different wine version for each game, as each game can have their own virtual drive.

    I downloaded the latest version (4.2.5) from PlayOnLinux. I don't know what version is in Ubuntu's repository, but maybe it's the same as in Mint's, which was 4.2.2. That probably doesn't matter much though.
     

    Attached Files:

  5. Robert FIN

    Robert FIN Monty n' Roll

    Joined:
    Nov 7, 2012
    Messages:
    1,363
    Location:
    Finland
    Hi!

    I'm new to Ubuntu and Linux and Wine and I'd love to get Civ IV working in my pc. I have Ubuntu 14.04. LTS and I've installed Civ IV Complete (means vanilla, Warlords and BTS) and BTS 3.19 update through PlayOnLinux (Wine 1.6.2).

    So the problem is that now when I try to launch the game it won't start, it just says something like "this doesn't work!"... I know that I have a complete guide for this just a few posts above me, but I think that the problem is the part where I should visit the WineHQ description. I tried the console script mentioned there but it didn't work. It probably goes differently with PlayOnLinux.. I'm completely new to Linux so this is not easy but I still think that I have quite okay understanding of computers so maybe I get this working with help.

    Thanks.
     
  6. Pangaea

    Pangaea Rock N Roller

    Joined:
    Sep 17, 2010
    Messages:
    4,489
    Sounds like you have tried to install with normal Wine. PlayOnLinux is easier I think, and it has the advantage that you can use different versions of Wine for different games or programs. I installed the game via the script you get with POL, and that worked very well. But like I mentioned above, there was still a problem that sometimes cropped up, for example with Stonehenge and Calendar. To fix that, I installed MSXML3. If you install it with POL, you can click on the virtual drive for Civ4 -> Configure -> Install component -> Locate MSXML3.

    I would at least try this and see if it works. This script uses the 1.4.1 version of Wine btw. Could be the last version doesn't work properly with the game. This is one of the big advantages with Playonlinux, that you can use different versions of Wine on the same computer, while normal Wine will use one version, which makes it harder to be compatible with different software and games.

    You can probably use the playonlinux version that is in your repository, which you can find in the software centre, or whatever it's called in Ubuntu.
     
  7. Yamps

    Yamps Chieftain

    Joined:
    Aug 30, 2007
    Messages:
    2,728
    Location:
    Zagreb, Croatia
    I'm also using Play on Linux on Ubuntu 14.04. It was important for me to also get BUFFY mod to work and this took some dll changes as suggested here:
    https://appdb.winehq.org/objectManager.php?sClass=version&iId=10158&iTestingId=24421

    This worked for me. :cool:
     
  8. Robert FIN

    Robert FIN Monty n' Roll

    Joined:
    Nov 7, 2012
    Messages:
    1,363
    Location:
    Finland
    Please help!

    I tried to replace msvcr71.dll with wine7.system's one but the game won't even open.. I have no idea what to do, I also tried the PlayOnLinux' own patch in install game -> Civ IV Complete way but it didn't work...


    EDIT: This is so damn annoying that I maybe have to get the money to Windows...
     
  9. Yamps

    Yamps Chieftain

    Joined:
    Aug 30, 2007
    Messages:
    2,728
    Location:
    Zagreb, Croatia
    Did BTS work without this replacement? In my case, this was only necessary for BUFFY.
     
  10. Robert FIN

    Robert FIN Monty n' Roll

    Joined:
    Nov 7, 2012
    Messages:
    1,363
    Location:
    Finland
    No.

    I haven't got even to the point that the game is loading yet...
     
  11. Pangaea

    Pangaea Rock N Roller

    Joined:
    Sep 17, 2010
    Messages:
    4,489
    That is odd indeed. All I can say is as above really. I have Linux Mint, which is based on Ubuntu, so should be same-ish there. And I installed with the POL script (the Complete edition) and the game worked fine, except that little issue I mentioned. To fix that, I installed the MSXML3 component and since then the game is running flawlessly.

    The script uses the 1.4.1 version of Wine, and I use the 32-bit version, but this should get downloaded automatically if you didn't have it before, by the script itself.

    You have enough available space and stuff like that, right, and proper rights to where you install it?

    Another issue MIGHT be the graphics display driver. I've heard this can mess up things, so check out that you have the most recent one, a proprietary driver, and not a default one. Not sure how this works in Ubuntu, but in Mint there is something called "Driver Manager", where I can select from a few options. In my system I've not had to install something that wasn't there from before, but I'm using one that's called Nvidia 331.113.
     
  12. Robert FIN

    Robert FIN Monty n' Roll

    Joined:
    Nov 7, 2012
    Messages:
    1,363
    Location:
    Finland
    I have AMD Radeon R9 280 GPU and I think that the drivers are just fine. I tried again yesterday by putting the Civ IV Complete disc to my dvd-drive and then going to PoL and using the script in the install games page. I got in to the point that I had completed the installation but then I have to wait for PoL to finish it or something. There is a "wait a minute" or similar window doing something but it took over hour and nothing happened. I gave up for that day.

    I don't understand..
     
  13. Yamps

    Yamps Chieftain

    Joined:
    Aug 30, 2007
    Messages:
    2,728
    Location:
    Zagreb, Croatia
    That might be okay, it sometimes just waits for something to end. Do you have the BTS shortcut on your desktop after that? If not, you could add it manually in POL options.

    You could also try manul install without the POL script.
     
  14. Ramkhamhaeng

    Ramkhamhaeng Chieftain

    Joined:
    Feb 24, 2014
    Messages:
    121
    Thanks for the msvcr71.dll-hint!
    Sometimes, the save loading of our Pitboss game fails with a 'corrupt file' message. This was a wine issue because the saves are ok.
    The deletion of msvcr71.dll and msvcp71.dll in all Civ4-folders fixed this problem. :)

    @Robert FIN's latest problem: Sounds like a hanging install dialog at the end of the installation process. This should be no problem because the installation is already done.
     
  15. Robert FIN

    Robert FIN Monty n' Roll

    Joined:
    Nov 7, 2012
    Messages:
    1,363
    Location:
    Finland
    I have the shortcuts but the game won't start by pressing them or when trying to "open an exe. file". Also I tried again to install and now I waited for longer time but the result was some kind of error.
     
  16. masaykh

    masaykh Chieftain

    Joined:
    Jan 16, 2012
    Messages:
    416
    For civ4 to run good you need to open your terminal emulator and navigate Beyond the sword folder, then you execute regsvr32 msxml3.dll
    after this open winecfg, click to Libraries tab
    and enter one-by-one next
    msvcr71
    msvcp71
    msxml3
    dx9_31
    dx9_33
    then change each of them to external and press ok

    If you see XML errors then try to run winetricks msxml3, it will ask you to download something like this http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html and put downloaded file to desired location, do suggested and rerun winetricks msxml3, it should fix problem.
    Playonlinux users dont need such actions, simply open settings and press add components, look for msxml3 and install it.
     
  17. Pangaea

    Pangaea Rock N Roller

    Joined:
    Sep 17, 2010
    Messages:
    4,489
    Over the last week I've had big mouse lag problems. No idea why, but it seems to occur more frequently in the game than the DE, which is mostly fine, but the issue persists a while after exiting the game too.

    I made a post about it here: http://forums.linuxmint.com/viewtopic.php?f=49&t=202714&sid=80af4492fda78948016de09e53367dba
    (wonky-looking link, but I hope it doesn't time out or something)

    Naturally, the mouse lagging and stuttering makes playing the game pretty much impossible. Do you know what might help?



    Specs
    Code:
        System:    Host: thunderstruck Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2)
                   Desktop: Gnome Distro: Linux Mint 17.1 Rebecca
        Machine:   Mobo: MSI model: Z87-G43 (MS-7816) version: 1.0 Bios: American Megatrends version: V1.6 date: 11/27/2013
        CPU:       Quad core Intel Core i5-4670K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27199.8
                   Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
        Graphics:  Card: NVIDIA GK104 [GeForce GTX 770] bus-ID: 01:00.0
                   X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1920x1080@60.0hz
                   GLX Renderer: GeForce GTX 770/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.82 Direct Rendering: Yes
        Audio:     Card-1: Intel 8 Series/C220 Series Chipset High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
                   Card-2: NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
                   Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
        Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
                   driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
                   IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
        Drives:    HDD Total Size: 2560.5GB (53.1% used) 1: id: /dev/sda model: ST2000VX000 size: 2000.4GB
                   2: id: /dev/sdb model: KINGSTON_SH103S3 size: 240.1GB 3: id: /dev/sdc model: ST3320620AS size: 320.1GB
        Partition: ID: / size: 30G used: 7.6G (27%) fs: ext4 ID: /home size: 141G used: 107G (81%) fs: ext4
                   ID: swap-1 size: 1.08GB used: 0.00GB (0%) fs: swap
        RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
        Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:36C
                   Fan Speeds (in rpm): cpu: N/A
        Info:      Processes: 168 Uptime: 27 min Memory: 1057.2/7929.6MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4 
     
  18. Civ Vicious

    Civ Vicious Chieftain

    Joined:
    Feb 4, 2011
    Messages:
    26
    I installed Ubuntu one year ago, and the reason I uninstalled it was because my Samsung External DVD writer Model SE-S084 wasn't working. This meant I couldn't install Civilzation IV. (Since my internal DVD drive is broken).

    I also had problems when I first intalled Windows 7 at first, with my intergrated graphics card. ATI RADEON EXPRESS 200 SERIES. Which stopped me from playing Civ 4. But that ended up being fixed once Windows 7 finally managed to get an update for that. Ironically, I also had problems at first with my external drive and Win7 also.

    Anyway, I'm sick of windows and I'd like to installed Ubuntu again. But for anyone who knows. Would I come up again with these same issues? Does anyone know if my external drive is actually supported with Ubuntu?

    I have a Compaq Presario SR1705UK.

    It's old, but the only thing I use it for is internet and old PC games. (mainly CIV)
     
  19. IPEX-731BA5DD06

    IPEX-731BA5DD06 Chieftain

    Joined:
    Dec 15, 2005
    Messages:
    2,472
    Location:
    Melbourne, Victoria, Australia
    p { margin-bottom: 0.25cm; line-height: 120%; }a:link { }

    Civilization 4 and BTS Guide to Playing on Linux Ubuntu 16.04.1 LTS





    1st, Installation.





    To Install Civilization 4, and the Add on packs, you'll need some emulation software, wine is What I'll refer to here.



    Version 2014) is Wine 1.6.2 VERY STABLE.



    Latest version is 2.0.2, Worked fine, EXCEPT for using another desktop/window. If you try to swap your desktop/window, to look at something else, it will cause the game to crash, otherwise it seems to play fine for the couple of turns I did.



    Big improvement on 2.0.1, but you have to stay in the desktop/window, that your booting Civ IV in, otherwise it will crash/freeze/stop responding.



    Tried to load up wine 1.8.6 to give it a try, couldn’t get it to load, keeps asking for unmet dependences with wine1.6. I give up, staying with 1.6.2 It WORKS. If it ain’t broken don’t fix it.



    Download and install this software, its so easy on Ubuntu, just use Ubuntu software centre (Applications/Ubuntu software centre). Or use the wine link winehq



    I wish to Emulate a XP windows for 64 Bit, and XP for 32 bit systems. Note Ubuntu in now 64 Bit, mostly, older Ubuntu systems were 32 bit. XP environment under wine , (Personal choice, old game, old environment) Use wine to install these, down load the files from Ubuntu Software Centre and install under wine



    Now your ready to Install Civilization 4.



    Install and PATCH Version 1.74, for Civilization 4 (Vanilla)



    Now install the addon packs as you have them.



    1. Warlords and PATCH latest version 2.08 (I don't have)

    2. Beyond the Sword and PATCH to Version 3.19 (I do have)




    This should install with no delays or problems. Now you have a shiny new installation of BTS.

    Should have 1.74, Warlords 2.08 if have ( I don't) and BTS 3.19 AFTER ALL fully patched and installed





    WineHQ - Sid Meier's Civilization IV Complete





    is the wine HQ Dedicated page to this game.







    Mods



    The Civilization Community has developed many mods (Modifications) to this game, to improve the game play, scenario's, Lets sample some I use.



    Blue Marble Gold 4.5, Bug 4.4, Bat 4.1, & Bull 1.2



    Blue Marble



    I can't stand the original colour scheme of Civ 4, I have to play with Blue Marble.



    Blue Marble Gold 4.5





    No 1. BUG



    Bug 4.4, , This stands for Beyond the sword Unaltered Game play. An Excellent mod, excellent support and dedicated team, though no longer in development.



    Its installation is simple, down load the Self installing file, Right click on the Exe file to install, and select Wine windows program loader. This will now install the program, just follow the Instructions.



    If you've just done a re/install of Beyond the Sword, you need to reboot the computer 1st, then install Bug.



    Note: with 64 bit wine, you need to load up a game, but don't use the ‘start now’ option, BEFORE you can install Bug.



    NOTE: - You’ll notice many options aren’t enabled, greyed out, to enable them, you need to install BULL, see below.





    No 2. BULL



    32 Bit system



    Bull Version 1.2 Now this is a bit different to install. To install as a stand alone mod, 1st, you must install it in the mods folder yourself.



    Location of this folder is;



    home\(Control H to revel hidden folders) .wine\users\(user name)\My Documents\My Games\Beyond the Sword\Mods

    Phew, what a directory tree.



    Spoiler :






    INSTALLING WITH BUG IN CUSTOM ASSETS - For playing with bull active all the time, succession games etc.



    To install BULL so that it is always active with your games (this will allow you to use it with succession games and games you open from the CivFanatics forum), you must copy the files and folders from BULL's Assets folder into your Custom Assets folder.



    C:\Documents and Settings

    <your user name>

    My Documents

    My Games

    Beyond the Sword

    Custom Assets



    Next copy the file Assets/CvGameCoreDLL.dll to BTS's Assets folder, renaming the original first. It's okay to leave a copy of it in the Custom Assets folder; it will be ignored by BTS.



    C:\Program Files

    Sid Meier's Civilization 4

    Beyond the Sword

    Assets

    CvGameCoreDLL.dll.original <-- rename by adding original or something onto the end

    CvGameCoreDLL.dll <-- then copy BULL's here





    BULL has been designed to have no files in common with BUG. If you installed BUG using the default Single-Player method, follow the CUSTOM ASSETS instructions above. If you installed BUG using the Multi-Player method, copy all of the files in BULL to the "BUG Mod x.x" folder, saying "Yes to All" to replace files (it will not actually replace any files).

    To check that you have loaded these mods correctly, just start a new game. Place your cursor over the flag of your Civilization and it will come up on print on the left. Bug Ver , Bull Ver Civ name, traits etc.



    Spoiler :




    Screen shot was 32 bit, look at the graphics *shudder*

    64 Bit system is slightly different.



    Spoiler :






    Instead of Custom assets folder, it ALL goes in the ASSETS folder of Beyond the sword, the folder with the Bull version of CvGameCoreDLL.dll You still rename the original *.dll file with .Original but copy ALL the folders and files of the Bull Mod Assets folder, to Beyond the swords assets folder.



    Spoiler :




    No 3. BAT



    The BAT mod 4.1, Beyond the sword Artistic Tweaks. This adds a lot of eye candy to your game.

    Same procedure, download the exe file, install under wine, put into mods folder and do amendment in Q & A Section to launch from desktop.



    Bat is loaded as a separate mod and will appear on the mod selection screen when you 1st log in, or See Q & A section on how to load it from desktop.



    Spoiler :




    Note: Bat contains Bug, Bat, and Bull all in one package, They are ALL THERE, but BAT is a separate mod.



    My current mod of flavour is Rise of Mankind - A New Dawn 2.2



    Note, it contains both BUG & BULL installed into mod.



    Beta 2.2 Latest SVN



    Here's a screen shot to drool over

    Spoiler :






    Install this mod, by downloading the Zip file Rise of Mankind - A New Dawn 2.1 or Beta 2.2



    Open the self executing file and it will install.



    Note: The mod now has a self updating file, located within the mod, called ‘and2_checker.exe’



    Use the built in installer, just be careful where it wants to install the files. It MUST go in the Mods folder, not the MODS folder. There are 2, both are separate and individual. Mods is located in

    Spoiler :








    CvAltRt.py file



    Now comes the fun part, took me 5 days' to get this right, all it takes you is 5 minutes of reading.



    Thanks to Emperor Fool (Thank you again) and Zappara, and ME!!!!! you need to alter the CvAltRoot.py file included with the Mod.



    This file is located in the Rise of Mankind Mod folder you've just extracted. Open this file with a text Editor. When finished, delete the .txt at end to make it a python file again.



    1st step- Windows XP emulation is assumed, alter for other operating software accordingly.



    Alter the Rootdir text at the base of this file, the PINK TEXT to read, (just over write)



    32 Bit System

    rootdir = “C:/My Documents/My Games/Beyond the Sword”



    Spoiler :




    64 Bit System



    rootdir = "H:/My Games/Beyond the Sword"



    Now you need to go to the Assets\Python folder of the Mod directory your currently in, paste into the Python folder the copy of the file, overwrite the existing copy, if any.



    Nb: Wine will automatically assume that '/home/(user name)/ is equal to C:/



    '/home/(user name)/Documents' = H:/ for 64 Bit operating systems.



    Spoiler :






    Now you can play rise of Mankind. So simple now with Version 1.6.2 of Wine



    Note on Formations, Contained in the launcher for Rise of Mankind, as an option.



    Other mods.



    Hmm just use the CvAltRoot.py file, Revolution DCM for BTS and Realism Invictus .



    Note K-Mod, won't work with Bull implemented as single player, you need bull as a mod, I just tried, (12/July/2013) both have own OriginalCivIV.dll and are not mutual compatible. If you have Bull installed as a single player option, you can't use K-Mod. The modder has stated on the forum, that they have only merged the parts of bull.dll that they thought necessary, and won't do the rest, it simply won't work with Bull installed in single player mode, see the Bull.dll readme for Mod installation instructions.



    Notes:, this works for Windows XP Emulation, others don't Know, similar directory structure.



    If CvAltRoot.py ISN’T contained in the mods, its attached to this post. Post the file in your top Mod directory (1st level) and your assets/python directory. Its all listed in the file.



    Question and Answers Section



    Q. I want to use an Earlier/Later Version, or another Version of Linux.

    A. Just use wine, same procedures, I use Ubuntu 16.04.1 64 bit LTS Edition is all. (Currently, August 2016)



    Q. Hey, I've got a Mac,



    ‘What about me,

    it isn't fair,

    I've had enough,

    I want my share’....



    A. ‘Can't you see,

    its in the file,

    just change the lines

    to follow the correct path’



    Q. Every time I use the scroll button on the mouse, it zooms right up close or out to Universal view, it scrolls slowly across the map, etc.

    A. 1.Edit the file ‘Globaldefines.xml’ in the XML folder of the mod, Cntl-f

    2.Search for ‘CAMERA_FORCE_TO_SMALLEST_MAX_DISTANCE’

    3.Change the Zero to a 1.

    When you do an update, the change will be overwritten, and you’ll have to manually revert it to this change. Comments won’t stop it being overwritten, as with SVN.





    Q. How do I load the mod from the Desktop,without opening the game 1st.?

    A. Copy Your relevant Civ 4 icon, and rename this copy to your mod to load. Right click upon this icon, select last option, Properties, and select Command. Hit your end Key to get to the end of this file, add the following code mod='\(Name of mod in your mods folder)\'



    Note Very important to get:-

    single quote \ (Mods name) \ single quote

    in correct order at both ends



    To change the icon to a custom icon, click on the icon in top left corner and now search for your custom icon that you want to use.



    Spoiler :




    Q. Hey, I've got Linux, not windoze, what's this C:/

    or Ha Ha, Its \ and NOT /

    A. Its EMULATING (Pretending) Windows XP DIRECTORY, under a Linux structure, hence C:/home/(user name)/My Games/Beyond the Sword



    Q. What happened to \home\.....\ you say one thing, then type C:/.

    A. Its the way the games designed, or windows handles it. I don't know, I'm not a programmer.



    Q. How do I play \( Linux) Start the game.

    A. It should have installed an icon on the desktop, if not, find the executable file, copy it to desk top, right click, make it executable, and locate icon, Click on blank square in top right of 1 page of file properties, search for your icon file. Or do as I do, and just double click on the saved game.



    Q. Hey, the mods don't work, are faulty, Buggy, etc

    A. Place your grievance with the various Mods forums.



    Q. I haven't got (user name), where and what is it.

    A. Its your Desktop name, usually your name.





    Q. Do I have to go from Root ( \ ) every time.

    A. No, I'm just showing the full Directory structure, start with \home or \(User name)



    Q. I want to use the command line, how do I do that.

    A. My heads spinning already, I can't help you there.



    Q. Aren't I just adding another layer to the game, won't it just suck more resources, etc.

    A. I've found, my own personal data, that it plays better, uses less resources. Linux does it better.



    Q. How do you know this works?

    A. I've tested this, over 5 day's, various other changes, combinations, satanic chants, and Voodoo. This loads 100%, is faster, and plays great. (Rise of Mankind Mod)



    Q. Hey, Mod X....?

    A. Mod X forums , not me.



    Q. Hey, what a lot of work install this, down load that, windows is so much simpler.

    A. How many service packs did you install, drivers, virus checkers, ram upgrades, video upgrades.? How much did Windozze cost you $$$$ Ubuntu 16.04.1 LTS = Free download. And supported for 5 Yr's FREE OF CHARGE.



    Q. Mine works without the changes you've suggested, what gives.

    A. Lucky you, mine worked as well, without the changes 1 out of 14 times, 1st time not a problem, it would load fully couple in a row, then crash anther 14 times. Rise of Mankind - A New Dawn Beta 2.2



    Q. How do I know I can trust you.

    A. What??? Trust ME!!!!!! ( Muah hahahhahaha) ROFLMAO
     

    Attached Files:

    Last edited: Aug 10, 2017
  20. huricanehrt

    huricanehrt Chieftain

    Joined:
    Jan 18, 2017
    Messages:
    1
    I want to install GOG version of Civilization IV Complete on Ubuntu 16.04 LTS.

    I use PlayOnLinux to do that. Unfortunately, the script which is approved by the PlayOnLinux team does not work for the GOG version of the game, so I need to install the game manually.

    I am probably doing something wrong as the installation never completes. It freezes at ~75%. It is still showing the message "Installing, please wait" but without any further progress. (I have to wait ~60 minutes to get to that point of the installation and then even longer to see that the installer is indeed frozen. This is really a pain as the trial and error method is useless in such a case.)

    How do I proceed with the installation (in PlayOnLinux):
    - install a nonlisted program in a new virtual drive
    - use another version of wine - 1.7.55 (32 bit)
    - configure wine - windows version Windows XP
    - install some libraries - corefonts, d3dx9, gdiplus, msxml3, tahoma
    - then I find the GOG installer file and proceed by the installation
    - after ~60 minutes, the installer freezes

    Please, what am I doing wrong?
     

Share This Page