DOWNLOAD LATEST VERSION Here

bakshi

Prince
Joined
Jan 31, 2010
Messages
389
How do I download this mod? I clicked all the links but none of the pages load.
 

NexusCron

Chieftain
Joined
Feb 20, 2010
Messages
1
Can anyone else get a link for Rhys 1184?(Rapidshare isn't working for some reason for me) I ask because I cannot update to 3.19, and I lost my CD's a long time ago cause some ass stole them, and I never got em back so i've had to rely on external drives to save my CIV 4 game stuff whenever I had to reformat, and it says CIV 4 itself was not correctly installed, but..Warlords and BTS never say that. And the auto updater picked up the 3.19 patch. (I DID have to give an explanation WHY i need Rhyse 1184)

But I ask because Rapidshare isn't workign for me, and I don't like it anyway.
 

Nor'easter

Emperor
Joined
Feb 25, 2007
Messages
1,767
Does the link to the "latest version" in the first post also include the unlocked versions of both the 3000 BC and 600 AD saves?

Sorry for this question, since I'm sure there's a simple answer somewhere on these forums, I just haven't found it. I have the version of RfC that came with BtS, patched to BtS 3.19, but it doesn't include the unlocked versions. (I downloaded the unlocked versions a long time ago, but had to reinstall Windows at one point, which meant reinstalling other programs like Civ 4, and couldn't find the unlocked versions any more.)

Will be grateful for any response. Thanks.
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,167
Location
東京藝術大学
I got a new PC some weeks ago and installed the latest version of RFC (1.186 I think), and I was able to play unlocked.
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,167
Location
東京藝術大学
Thanks, I'll edit my post to avoid unnecessary confusion :)
 

Harrier

Deity
Joined
Feb 19, 2002
Messages
2,424
Location
UK
The last update to the first post of this thread, by Rhye; was about 10 months ago. So is this a dead mod kept alive by fans? ;):D:p:rolleyes::mischief:
 

nody

Emperor
Joined
Nov 28, 2004
Messages
1,168
Location
Noviomagus, Batavia
No. Rhye is working on an update right now.
He sometimes checks in on this forum, recently at least ones a week.

He just doesn't make tiny updates every month, like some other modders.

I think it's going to have a lot of changes and fixes, because I read somewhere it's going to be the last version.
 

JosEPh_II

TBS WarLord
Joined
Jun 20, 2007
Messages
16,536
Location
Western IL. cornfields
Well it's now August and still no sign.

Looks like 1.186 is The last version.

JosEPh
 

dnewhous

Chieftain
Joined
Oct 27, 2006
Messages
63
I downloaded the latest BTS version, and it does not appear to be compatible with Civ 4 Complete. Or did I do something wrong?
 

AmazingA

Chieftain
Joined
Aug 2, 2010
Messages
1
Location
London, UK
Hi!
I've got Civ 4 complete and play RFC on BTS, but I haven't updated it since I got it ages ago! I've been reading up ALOT and have come to the conclusion that you need to first download the patch for BTS before you do all the unzipping etc in the mod folder. But I downloaded the patch then did all the rest but the game kept crashing when I tried to load it anyway! So I checked for updates for BTS again and it told me that the 3.19 patch is available even though I just downloaded the patch and restarted the game! I've done this about 3/4 times now and it still doesn't work! I've got the new RFC folder saved separately and made a backup copy of the original mod just in case, but nothing I try seems to work! Can anyone tell me how to install the update? Its really frustrating because my version is old and I want to get this update!!! Can anyone help?
Thank you! :confused:
 

JujuLautre

Deity
Joined
Apr 9, 2007
Messages
3,112
Location
Kansai, Japan
Did you use the in-game updater to go to 3.19 ?
If so drop it and download the patch directly from this website. The in-game updater is buggy.

If you already downloaded from this website... Well, I dunno
 

Tasunke

Crazy Horse
Joined
Mar 20, 2009
Messages
2,800
Location
the 1800s
earlier today ... some of the RFC.net links worked .... today, nothing works, replaced by a godaddy redirect.

did RFC.net die tonight? or is it just me ....
 
Top Bottom