• Civilization 7 has been announced. For more info please check the forum here .

For all those who are having patch and BTS installation problems!

almeida_cohen

Chieftain
Joined
May 1, 2006
Messages
46
Location
Melbourne
Hey everyone,

If like me you have almost thrown your computer off an incredibly large building, then I may be able to help!
I bought BTS and tried to install it but like alot of people it would quit installing when trying to install the newest patch. After scanning the forum for what seemed like an eternity I have the answer!

I should mention that I do have Vista (a pain in the butt by itself, without the hassles of other software!)

Anyway:

In order to install the patch 1.74 and Beyond the Sword all I did was:

Delete the folder: C:\Program Files\Common Files\InstallShield\Professional

Make sure you copy it to another safe location incase something happens!

However cutting an pasting wont get rid of it so you will need to actually DELETE the folder.

For me doing this worked like a charm!

I hope this helps!

almeida_cohen
 
Your solution sounds simple enough to work, but my problem is a little different. (Win XP, CDs not downloads)
I tried to bypass the patch installation issue by downloading and installing the patch first.
The 1.74 patch can't install because "no version of Civ4 is installed on this computer".
Add remove programs shows no Civ4.
Setup shows no uninstall option.
During installation of civ4 the "insert disc 3" dialog box quit responding.
BUT, after restarting, the game played with no problems.
I am able to install the game as many times as I want, but the same thing happens every time.

My registry showed the installation directory in C:/program files even though I installed it on drive I:
So I copied the entire folder to C:/Program files.
I can now run the game either from C: or I: with no problems.

I think I will try to install it on another machine and see what happens.
 
I would love to be able to help with your problem but I am the worst person to ask lol I have no idea when it comes to how or why computers do things, I only posted this solution cause it worked for me...sorry that you are having so much trouble!

Good Luck,

almeida_cohen
 
Top Bottom