Single Player bugs and crashes v42 download - After April 2022

Raijin

Chieftain
Joined
Jul 4, 2008
Messages
12
I cant open Tech Tree or Civis. Getting all over Error Messages like
upload_2022-6-9_21-10-28.jpeg

upload_2022-6-9_21-10-41.jpeg
 

raxo2222

Time Traveller
Joined
Jun 10, 2011
Messages
9,441
Location
Poland
I cant open Tech Tree or Civis. Getting all over Error Messages likeView attachment 630713
View attachment 630714
You failed to install mod correctly.

Installation guide:
1. Never overwrite old version of mod with new one - always delete old version, as files are often moved, renamed or removed.

2. Mod must be named Caveman2Cosmos and won't work if placed in C:\Users\<USERNAME>\Documents\My Games\Beyond the Sword\MODS.
If its located there - delete it from that place

So valid install paths will look like this:
For GoG this will be something like: C:\Program Files (x86)\Civilization IV Complete\Civ4\Beyond the Sword\Mods\Caveman2Cosmos
For steam it will be something like: C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization IV Beyond the Sword\Beyond the Sword\Mods\Caveman2Cosmos
Assets folder would exist in Caveman2Cosmos folder - ensure it isn't nested!

3. If game is on system drive "c:", then you need to run as admin.
 

biggboy

Chieftain
Joined
Oct 31, 2013
Messages
22
OK, fresh install of 42.1, right directories etc., Win10, just updated.

Then I start (as admin), the C2C mod can be seen ok in the advanced mod selection mode,but it crashes about halfway into loading the C2C assets, I have now done 3 downloads and 6 or so fresh installs....

Any ideas??
 

Mr Smith

Warlord
Joined
Dec 28, 2008
Messages
130
Location
Moscow's suburbs
I have now done 3 downloads and 6 or so fresh installs....

Any ideas??
Mod folder has to be called Caveman2Cosmos. Also it's a common thing to have Civ4 crash on Win10, a lot of people complain about it, have you tried using Win7 compatibility? It could've been fixed long ago, try SVN instead, that's where patches and fixes are. "Stable" only gets critical updates shortly after release and you can see there were only 2 of them, yet 42.1 isn't even all that stable.

Is your BTS 3.19?
 

Maltazard

Prince
Joined
Nov 19, 2008
Messages
319
Also since I haven't seen anyone sayt it, if you're on Steam remember to use the original_release_unsupported "beta" version in the properties.
 

devlman127

Chieftain
Joined
Aug 27, 2022
Messages
4
Playing on Snofru's Large Space Map 6, When advancing past this specific turn, the game instantly crashes to desktop.
Feel free to ask me for more information cause I have no Idea what could be happening.
Edit: Ran on Win7 Comp mode, didin't work. Gonna try to use the original release, see if that works.

Edit 2: That seemed to work, I got onto the next turn and I even see a few Icons that were missing before. Thanks Maltazard and Mr Smith.
 

Attachments

  • Hadrian September 18, AD-1597.CivBeyondSwordSave
    7 MB · Views: 4
  • MiniDump-v42.0.6871-20220801-180051.zip
    75.6 KB · Views: 3
Last edited:

devlman127

Chieftain
Joined
Aug 27, 2022
Messages
4
Original release on steam is required anyhow. I'm assuming this is SVN; updated to yesterday's release or no?
I am not using SVN. First heard about it existing today, actually.
Even if I wasn't mid-playthrough I don't think I want to fiddle with building through the SVN, at least the stable works now
 

Blazenclaw

eccentric eclectic
Joined
Sep 19, 2010
Messages
410
I am not using SVN.
Aaaand I am an idiot that should learn to properly read thread titles :crazyeye:
You're all good, sorry! I just happened to break something on SVN recently, so am frantically trying to fix things...
Anyway, feel free to post if anything else arises. There's a discord too for more active responses if you're into that.
 

Somebody613

Emperor
Joined
Nov 18, 2019
Messages
1,447
Aaaand I am an idiot that should learn to properly read thread titles :crazyeye:
Don't worry, it often confuses me as well, lol.
I think it should be made more obvious via some TAGS put IN FRONT of the title, or something.
Like:
[SVN v.42] Single Player bugs.
[RELEASE v.42] Single Player bugs.
Or similarly.
 

tasans

Chieftain
Joined
Oct 5, 2012
Messages
12
Hey guys, I'm getting a ctd every time end turn is applied and I have no idea why.

I've attached the autosave before the ctd, the Python Err 2 log, and 4 different .dpm files.
 

Attachments

  • PythonErr2.7z
    1.4 KB · Views: 3
  • AutoSave_June 7, AD-1652.CivBeyondSwordSave
    10.8 MB · Views: 5
  • Minidumps.7z
    34 KB · Views: 3

Culthrasa

Chieftain
Joined
Nov 6, 2018
Messages
9
Been playing for a while now, and thz for all the lost hours of fun! :)

Recently got into a repeatable CTD. just end turn...Files attached.

thz in advance!

EDIT: solved in SVN. no action needed...
 

Attachments

  • Culthrasa September 28, AD-0531.CivBeyondSwordSave
    7.3 MB · Views: 1
  • MiniDump-v42.0.6871-20220916-192317.dmp.zip
    18.2 KB · Views: 1
Last edited:

Guvnor

Chieftain
Joined
Apr 4, 2022
Messages
4
I was playing v41 just fine, and installed v42 this evening. Now upon launch I get this perpetual XML error. If I click OK or the X it just comes back again ad infinitum, and I have to CTRL+ALT+DEL and end the process manually to make it go away.

The mod files are in G:\Steam\steamapps\common\Sid Meier's Civilization IV Beyond the Sword\Beyond the Sword\Mods\Caveman2Cosmos (the same location I used for the previous version, without issue) I've verified that the U_Cultural_CIV4UnitInfos.xml file exists in Assets\XML\Units but I'm not sure what else to do beyond that.

1667110057655.png
 

Guvnor

Chieftain
Joined
Apr 4, 2022
Messages
4
Probably because you've overwritten it instead of doing a clean install ? (Of the mod, non need for a clean install of Civ/BtS itself...)
That would, in fact, be the reason. :hammer2:

Up and running now, though I did have to start a fresh game.
 
Top Bottom