• Civilization 7 has been announced. For more info please check the forum here .

Single Player bugs and crashes v42 plus (SVN) - After April 2022

Actually, might my bug be because I'm not setting up the SVN right? For some reason, there doesn't seem to be an "export without versioned files" option, only "export all files" and "export all versioned files".

Edit: I think I've got it working. Had to run the game as an administrator.
 
Last edited:
A weird bug this time, if I kill a cultural hero belonging to another nation it registers it as my unit. Latest SVN.
 
What do you mean by register, just a text bug in the log message or something more?
I could have phrased it better sorry. After a little more research and a few more times it happening, I figured it out it is just the sound playing when I kill a hero. The sound you get when you lose an unit. The log registers it fine, but the sound keeps playing.

Spoiler Screenshot :
1673030346687.png
 
Hello,

Getting a repeatable CTD on the attached save. Just updated to 11531.

I'm not having a MAF error or anything like that. Just crashes while the computer players are doing their turn.

Any ideas, please?

Thanks!
Working on it, almost fixed now, just doing some final testing.
 
However, your save is pretty toast, I keep getting memory allocation failure for a good word on it. Fixing the CTD allowed me to end turn, but then the game crash after I get to see a wonder completed splash screen due to memory allocation problems. The map is quite big.
I generally play without movies/splash screens, etc.

I'll test the save whenever the SVN is updated.
 
@Toffer90,

I want to say this, A Big THANK YOU for your diligence and support you give to this Mod. Again, Thank You! :thumbsup: :king:
 
Oh yeah, something I have noticed but keep forgetting to mention. Landlocked cities can build the Sea Mascot "bldg".
 
Just updated to the latest SVN version (11532) and am finding that random units are disappearing after moving. Note that I am using the latest MegaCiv MOD and playing as the Canadians. Also, the previous SVN versions did NOT exhibit this behaviour.
In the attached save, go to the SE portion of the map where you will see 4 healing Deceres and one Ancient workboat. Move the workboat south and notice it disappears.
Reload the save but this time, group the Deceres and workboat and move them. This time, the workboat continues to exist. If you end the turn, then ungroup the workboat and move it, it again disappears.
Also happened to a dog worker I had in the top, middle area.
 

Attachments

  • workboat disappears after moving.CivBeyondSwordSave
    5.6 MB · Views: 13
Just updated to the latest SVN version (11532) and am finding that random units are disappearing after moving. Note that I am using the latest MegaCiv MOD and playing as the Canadians. Also, the previous SVN versions did NOT exhibit this behaviour.
In the attached save, go to the SE portion of the map where you will see 4 healing Deceres and one Ancient workboat. Move the workboat south and notice it disappears.
Reload the save but this time, group the Deceres and workboat and move them. This time, the workboat continues to exist. If you end the turn, then ungroup the workboat and move it, it again disappears.
Also happened to a dog worker I had in the top, middle area.
On it, do you by chance remember what SVN revs you were on before updating?

Edit: Ok, so the bug wasn't there just one rev back, i.e. worked fine at 11531.
Edit2: Should be easy to fix.
 
Last edited:
Just updated to the latest SVN version (11532) and am finding that random units are disappearing after moving. Note that I am using the latest MegaCiv MOD and playing as the Canadians. Also, the previous SVN versions did NOT exhibit this behaviour.
In the attached save, go to the SE portion of the map where you will see 4 healing Deceres and one Ancient workboat. Move the workboat south and notice it disappears.
Reload the save but this time, group the Deceres and workboat and move them. This time, the workboat continues to exist. If you end the turn, then ungroup the workboat and move it, it again disappears.
Also happened to a dog worker I had in the top, middle area.
Ok, fix is on its way to SVN, rev 11533 should be available in 30-45 minutes time.
 
Something seems to be wrong with the religious disabling. I have Kemeticism as my state religion (and indeed the only religion in my empire) but the Karnak Temple Complex is disabled. Save attached. Rome is the holy city.

Recalculating modifiers fixed the issue, but it's obviously still a bug!

I suspect this may have happened because I created the shrine very early - I had a spare great prophet (from grabbing Mesopotamianism earlier), so I founded the religion and built the shrine all in one turn, then switched out of folklore, and then a few turns later once the anarchy was over I adopted Kemeticism as a state religion. Or possibly the shrine is just missing from some "enable this when you switch to Kemeticism" check somewhere.
 

Attachments

  • C2C Game 4.CivBeyondSwordSave
    6.4 MB · Views: 12
got a ctd when trying to take over the city in the pic, BUT if i leave a unit there from the other civ its ok to take the city withOUT ctd???
 

Attachments

  • ctd.JPG
    ctd.JPG
    350.5 KB · Views: 16
  • Angel33.zip
    4.9 MB · Views: 13
I was really hoping the kinks had been worked out of the new culture system, I had no issues until now. Random square switched over to another nation's culture. On the latest SVN plus save attached.

Spoiler Culture Weirdness :
1673324924980.png
 

Attachments

  • Upload.7z
    2.6 MB · Views: 16
Last edited:
In my game, my governers only ever want to pick engineers for specialists. Even when I'm building research and scientists are superior in all regards.

(The relevant city is Rome.)
 

Attachments

  • C2C Game 4.CivBeyondSwordSave
    6.9 MB · Views: 15
Top Bottom