1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

A New Dawn Bug Reports and Feedback

Discussion in 'Rise of Mankind: A New Dawn' started by 45°38'N-13°47'E, Dec 3, 2009.

Thread Status:
Not open for further replies.
  1. NightKev

    NightKev Chieftain

    Joined:
    Nov 8, 2010
    Messages:
    31
    I seem to be having trouble joining saved games in MP; it gets stuck at the "choose a civ" screen (none of them actually load, it just says 'loading civ list' forever). We're using 1.75c. I would try hosting but he can't join my games :undecide:.
    Here's an example save.
     

    Attached Files:

  2. Lord Mayor

    Lord Mayor Chieftain

    Joined:
    Jun 25, 2011
    Messages:
    5
    the so-called major bug with farms on tundra tiles may happen because according to civilopedia ice acts as a source of fresh water I had the same case yesterday
     
  3. BlueTemplar

    BlueTemplar Prince

    Joined:
    May 14, 2006
    Messages:
    396
    I can't give Flanking 2 to my tanks and Light Tanks.
     
  4. jackehehe

    jackehehe Chieftain

    Joined:
    Jun 28, 2008
    Messages:
    42
    Hi,

    I posted here some time ago about RAND crashing when I tried to capture a city. Unfortunately no one seemed to be able to help me and the intersest for that issue died out. So I decided to start a new game instead. Now, after several hours of gameplay, the game has started to crash again, in the exact same situation. I've turned of barbarian civs and all revolution mod features as per the recomendations from Kushling and others that tried to help me.

    The game crashes when I try to capture the city Bangkok. I can capture other cities, but when I cature this specific city the game crashes. Can someone please shine some light on this? I really enjoy this modmod and the thought of going back to AND without RAND is not very apealing =(

    I'm uploading logs and a save with this post. I've got a fairely good computer and I'm using RAND 1.75 with patch C.

    Cheers,
    Jackehehe
     

    Attached Files:

  5. Koshling

    Koshling Vorlon

    Joined:
    Apr 11, 2011
    Messages:
    9,254
    I'm not sure anyone is currently supporting 1.75, which is probably why you didn't get much repsonse. All work in the past 9 months has been on 1.76 and has fixed a ton of bugs in 1.75. The only person who was around in 1.75 days and is still active on the modders side is Afforess as far as I know. He might be able to help you, but I think he is also focused on 1.76
     
  6. os79

    os79 Deity

    Joined:
    Mar 14, 2009
    Messages:
    3,094
    Location:
    Eastern USA Coast
    Look at Horse units' XML entry for FreePromotions (the tag is at the end of unit's entry.)
    Then copy that tag to tanks you like to have that promotion.
     
  7. Lord Mayor

    Lord Mayor Chieftain

    Joined:
    Jun 25, 2011
    Messages:
    5
    Jackehehe, is this happening when you try to capture cities near north/south pole? I get this every time I do, but so far I only played on maps where you cant build cities within 2 tiles of the end of the map because of this...
     
  8. BlueTemplar

    BlueTemplar Prince

    Joined:
    May 14, 2006
    Messages:
    396
    I'm posting so that this bug is corrected in the next patch...
     
  9. JosEPh_II

    JosEPh_II TBS WarLord

    Joined:
    Jun 20, 2007
    Messages:
    16,390
    Gender:
    Male
    Location:
    Western IL. cornfields
    Are you guys using the Maps with the RoM_ prefix? Or standard BtS maps? Can make a big difference.

    JosEPh
     
  10. os79

    os79 Deity

    Joined:
    Mar 14, 2009
    Messages:
    3,094
    Location:
    Eastern USA Coast
    He knows about it. Look at Cavalry thread by Afforess in this forum.
     
  11. Stormwind

    Stormwind King

    Joined:
    Dec 7, 2008
    Messages:
    697
    I ran into a crash at the same turn everytime. The game was begun as early as Beta 3 (IIRC) and kept through the revisions per max compat save. Ran fine until this turn, which crashes in Beta 5 and also with revision 508. Of course, this crash maybe simple because Civ4 can't handle all that is happening in the game.

    Logs from a crash and save attached. Can provide saves up to 5 turns before this one.

    View attachment 296001
    View attachment 296000
     
  12. Koshling

    Koshling Vorlon

    Joined:
    Apr 11, 2011
    Messages:
    9,254
    I'll take a look. What do I need to do from this save to get to the crash? Just end-turn?

    Edit - nvm - save game pinned it down. It's a bug in the ROM Python. I don't know much about Python so just adding details here so that someone who does can fix it. The bug will cause a crash once you research TECH_KNOWLEDGE_MANAGEMENT as far as I can see. Here is the offending Python (from ROMEventManager.py):
    Code:
    	def onUnitBuilt(self, argsList):
    		'Unit Completed'
    		city = argsList[0]
    		unit = argsList[1]
    		player = PyPlayer(city.getOwner())
    
    		# if player has Technocracy civic active, give free promotion to unit
    		iPlayer = gc.getPlayer(city.getOwner())
    		if gc.getTeam(iPlayer.getTeam()).isHasTech(self.iTECH_KNOWLEDGE_MANAGEMENT):
    			[B]iFutureCivicOption = CvUtil.findInfoTypeNum(gc.getCivicOptionInfo,gc.getNumCivicOptionInfos(),"CIVICOPTION_FUTURE")[/B]
    			iTechnocracy = CvUtil.findInfoTypeNum(gc.getCivicInfo,gc.getNumCivicInfos(),"CIVIC_TECHNOCRACY")
    
    			[B]iFutureCivic = iPlayer.getCivics(iFutureCivicOption)[/B]
    
    			if (iFutureCivic == iTechnocracy):
    				if ( gc.getTeam(iPlayer.getTeam()).isHasTech(gc.getInfoTypeForString("TECH_SMART_DUST")) == true ):
    					iSensors =  CvUtil.findInfoTypeNum(gc.getPromotionInfo, gc.getNumPromotionInfos(),'PROMOTION_SENSORS')
    					if (unit.isPromotionValid(iSensors)):
    						unit.setHasPromotion(iSensors, True)
    The bolded lines are the root cause. AND does not define CIVICOPTION_FUTURE (CIVIC_TECHNOCRACY is under Power in AND), so the first line returns -1 (NO_CIVIC_OPTION). When that is passed to iPlayer.getCivics in the second bolded line a crash results. I'll see if I can make the DLL fail-safe (ish anyway!) against this kind of Python error, but the actual fix needed (from someone that knows Python) is two-fold:
    1. Change the Python code to explicilty check for NO_CIVIC_OPTION before blithely using the value it got back from the first call
    2. Update the ROM event code to match the civics present in AND
    I'll let you know when I have made a 'fail-safe' change to the DLL, but it's not a trivial one since I have to return some value to the bad call, and whetever I do return is likely to then come back as a reference to a supposed-civic-object later so I'll have to add protection to all the pyCivic methods as well as this originating method. Probably going to return NULL and check for it on all future calls, but it'll mean modifiying quite a few py... stubs in the DLL.

    As a manual temporary workaround just delete that event handler from the Python file I indicated above

    Edit 2 - the DLL safety fix is actually much easier than I first though. The Python will still need doing to restore the correct functionality, but I expect to be able to push the fail-safe fix to the DLL source later today. If nobody who knows Python steps up in the next 24 hours or so I'll try to do that too.

    Edit 3 - your save game has a SECOND crash later in the turn, which I have not yet been able to pin down (but I'll keep looking at it)
     
  13. Stormwind

    Stormwind King

    Joined:
    Dec 7, 2008
    Messages:
    697
    Thx for looking into this.
     
  14. Koshling

    Koshling Vorlon

    Joined:
    Apr 11, 2011
    Messages:
    9,254
    Ok, finally got to the bottom of your second crash. Again I can explain the issue and offer a manual temporary workaround, but again it's not a C++ issue and I don't know how to fix it at root, so posting details for someone who does (Afforess probably??).

    The issue is that in the turn in question you research TECH_WIRELESS_ELECTRICITY, which enables UNIT_WALKER_MECH. The walker mech replaces mech infantry, so all the mech infantry you are currently building (7 cities are doing so in fact) switch to walkers instead. At least one actually produces a walker that turn. Unfortunately the graphical assets for UNIT_WALKER_MECH are fubar'd, and the result is that the game crashes when it tries to render one.

    You can see this by starting a custom game with advanced start, in future era (can set to have 0 AIs on a tiny map for the purposes of demonstration and debugging). Place one city and select units in the advanced start - the walker mech appears as a pink square in the unit selection dialog (which is what happens for a missing asset I think).

    Until someone is able to fix this you'll have to disable the walker mech for now. Easiest way is to give it a cost of -1, which the game interprets as not buildable by normal means. In Assets/Xml/Units/Civ4UnitInfo.xml locate the tag for UNIT_MECH_WALKER and edit as below (the bolded line):
    Code:
    		<UnitInfo>
    			<Class>UNITCLASS_WALKER_MECH</Class>
    			<Type>UNIT_WALKER_MECH</Type>
    			<UniqueNames/>
    			<Special>NONE</Special>
    			<Capture>NONE</Capture>
    			<Combat>UNITCOMBAT_HITECH</Combat>
    			<Domain>DOMAIN_LAND</Domain>
    			<DefaultUnitAI>UNITAI_ATTACK_CITY</DefaultUnitAI>
    			<Invisible>NONE</Invisible>
    			<SeeInvisible>INVISIBLE_CAMOUFLAGE</SeeInvisible>
    			<Description>TXT_KEY_UNIT_WALKER_MECH</Description>
    			<Civilopedia>TXT_KEY_UNIT_WALKER_MECH_PEDIA</Civilopedia>
    			<Strategy>TXT_KEY_UNIT_WALKER_MECH_STRATEGY</Strategy>
    			<Advisor>ADVISOR_MILITARY</Advisor>
    			<bAnimal>0</bAnimal>
    			<bFood>0</bFood>
    			<bNoBadGoodies>0</bNoBadGoodies>
    			<bOnlyDefensive>0</bOnlyDefensive>
    			<bNoCapture>0</bNoCapture>
    			<bQuickCombat>0</bQuickCombat>
    			<bRivalTerritory>0</bRivalTerritory>
    			<bMilitaryHappiness>1</bMilitaryHappiness>
    			<bMilitarySupport>1</bMilitarySupport>
    			<bMilitaryProduction>1</bMilitaryProduction>
    			<bPillage>1</bPillage>
    			<bSpy>0</bSpy>
    			<bSabotage>0</bSabotage>
    			<bDestroy>0</bDestroy>
    			<bStealPlans>0</bStealPlans>
    			<bInvestigate>0</bInvestigate>
    			<bCounterSpy>0</bCounterSpy>
    			<bFound>0</bFound>
    			<bGoldenAge>0</bGoldenAge>
    			<bInvisible>0</bInvisible>
    			<bFirstStrikeImmune>0</bFirstStrikeImmune>
    			<bNoDefensiveBonus>0</bNoDefensiveBonus>
    			<bIgnoreBuildingDefense>1</bIgnoreBuildingDefense>
    			<bCanMoveImpassable>0</bCanMoveImpassable>
    			<bCanMoveAllTerrain>0</bCanMoveAllTerrain>
    			<bFlatMovementCost>0</bFlatMovementCost>
    			<bIgnoreTerrainCost>0</bIgnoreTerrainCost>
    			<bNukeImmune>0</bNukeImmune>
    			<bPrereqBonuses>0</bPrereqBonuses>
    			<bPrereqReligion>0</bPrereqReligion>
    			<bMechanized>1</bMechanized>
    			<bSuicide>0</bSuicide>
    			<bHiddenNationality>0</bHiddenNationality>
    			<bAlwaysHostile>0</bAlwaysHostile>
    			<bWorkerTrade>0</bWorkerTrade>
    			<bMilitaryTrade>0</bMilitaryTrade>
    			<UnitClassUpgrades/>
    			<UnitClassTargets/>
    			<UnitCombatTargets/>
    			<UnitClassDefenders/>
    			<UnitCombatDefenders/>
    			<FlankingStrikes/>
    			<UnitAIs>
    				<UnitAI>
    					<UnitAIType>UNITAI_ATTACK</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    				<UnitAI>
    					<UnitAIType>UNITAI_ATTACK_CITY</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    				<UnitAI>
    					<UnitAIType>UNITAI_RESERVE</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    				<UnitAI>
    					<UnitAIType>UNITAI_COUNTER</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    				<UnitAI>
    					<UnitAIType>UNITAI_CITY_DEFENSE</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    				<UnitAI>
    					<UnitAIType>UNITAI_COLLATERAL</UnitAIType>
    					<bUnitAI>1</bUnitAI>
    				</UnitAI>
    			</UnitAIs>
    			<NotUnitAIs/>
    			<Builds/>
    			<ReligionSpreads/>
    			<CorporationSpreads/>
    			<GreatPeoples/>
    			<Buildings/>
    			<ForceBuildings/>
    			<HolyCity>NONE</HolyCity>
    			<ReligionType>NONE</ReligionType>
    			<StateReligion>NONE</StateReligion>
    			<PrereqReligion>NONE</PrereqReligion>
    			<PrereqCorporation>NONE</PrereqCorporation>
    			<PrereqBuilding>NONE</PrereqBuilding>
                                          <PrereqTech>TECH_WIRELESS_ELECTRICITY</PrereqTech>
                                          <TechTypes/>
    			<BonusType>NONE</BonusType>
    			<PrereqBonuses/>
    			<ProductionTraits/>
    			<Flavors/>
    			<iAIWeight>0</iAIWeight>
    [B]			<iCost>-1</iCost>[/B]
    			<iHurryCostModifier>50</iHurryCostModifier>
    			<iAdvancedStartCost>100</iAdvancedStartCost>
    			<iAdvancedStartCostIncrease>0</iAdvancedStartCostIncrease>
    			<iMinAreaSize>-1</iMinAreaSize>
    			<iMoves>3</iMoves>
    			<bNoRevealMap>0</bNoRevealMap>
    			<iAirRange>0</iAirRange>
    			<iAirUnitCap>0</iAirUnitCap>
    			<iDropRange>0</iDropRange>
    			<iNukeRange>-1</iNukeRange>
    			<iWorkRate>0</iWorkRate>
    			<iBaseDiscover>0</iBaseDiscover>
    			<iDiscoverMultiplier>0</iDiscoverMultiplier>
    			<iBaseHurry>0</iBaseHurry>
    			<iHurryMultiplier>0</iHurryMultiplier>
    			<iBaseTrade>0</iBaseTrade>
    			<iTradeMultiplier>0</iTradeMultiplier>
    			<iGreatWorkCulture>0</iGreatWorkCulture>
    			<iEspionagePoints>0</iEspionagePoints>
    			<TerrainImpassables/>
    			<FeatureImpassables/>
    			<TerrainPassableTechs/>
    			<FeaturePassableTechs/>
    			<iCombat>125</iCombat>
    			<iCombatLimit>100</iCombatLimit>
    			<iAirCombat>0</iAirCombat>
    			<iAirCombatLimit>0</iAirCombatLimit>
    			<iXPValueAttack>6</iXPValueAttack>
    			<iXPValueDefense>6</iXPValueDefense>
    			<iFirstStrikes>0</iFirstStrikes>
    			<iChanceFirstStrikes>0</iChanceFirstStrikes>
    			<iInterceptionProbability>0</iInterceptionProbability>
    			<iEvasionProbability>0</iEvasionProbability>
    			<iWithdrawalProb>0</iWithdrawalProb>
    			<iCollateralDamage>110</iCollateralDamage>
    			<iCollateralDamageLimit>100</iCollateralDamageLimit>
    			<iCollateralDamageMaxUnits>10</iCollateralDamageMaxUnits>
    			<iCityAttack>25</iCityAttack>
    			<iCityDefense>25</iCityDefense>
    			<iAnimalCombat>0</iAnimalCombat>
    			<iHillsAttack>0</iHillsAttack>
    			<iHillsDefense>0</iHillsDefense>
    			<TerrainNatives/>
    			<FeatureNatives/>
    			<TerrainAttacks/>
    			<TerrainDefenses/>
    			<FeatureAttacks/>
    			<FeatureDefenses/>
    			<UnitClassAttackMods/>
    			<UnitClassDefenseMods/>
    			<UnitCombatMods>
    				<UnitCombatMod>
    					<UnitCombatType>UNITCOMBAT_HELICOPTER</UnitCombatType>
    					<iUnitCombatMod>25</iUnitCombatMod>
    				</UnitCombatMod>
    				<UnitCombatMod>
    					<UnitCombatType>UNITCOMBAT_GUN</UnitCombatType>
    					<iUnitCombatMod>100</iUnitCombatMod>
    				</UnitCombatMod>
    				<UnitCombatMod>
    					<UnitCombatType>UNITCOMBAT_TRACKED</UnitCombatType>
    					<iUnitCombatMod>25</iUnitCombatMod>
    				</UnitCombatMod>
    			</UnitCombatMods>
    			<UnitCombatCollateralImmunes/>
    			<DomainMods/>
    			<BonusProductionModifiers/>
    			<iBombRate>0</iBombRate>
    			<iBombardRate>0</iBombardRate>
    			<SpecialCargo>NONE</SpecialCargo>
    			<DomainCargo>NONE</DomainCargo>
    			<iCargo>0</iCargo>
    			<iConscription>14</iConscription>
    			<iCultureGarrison>16</iCultureGarrison>
    			<iExtraCost>2</iExtraCost>
    			<iAsset>6</iAsset>
    			<iPower>400</iPower>
    			<UnitMeshGroups>
    				<iGroupSize>3</iGroupSize>
    				<fMaxSpeed>1.75</fMaxSpeed>
    				<fPadTime>1</fPadTime>
    				<iMeleeWaveSize>3</iMeleeWaveSize>
    				<iRangedWaveSize>3</iRangedWaveSize>
    				<UnitMeshGroup>
    					<iRequired>3</iRequired>
    					<EarlyArtDefineTag>ART_DEF_UNIT_WALKER_MECH</EarlyArtDefineTag>
    				</UnitMeshGroup>
    			</UnitMeshGroups>
    			<FormationType>FORMATION_TYPE_DEFAULT</FormationType>
    			<HotKey/>
    			<bAltDown>0</bAltDown>
    			<bShiftDown>0</bShiftDown>
    			<bCtrlDown>0</bCtrlDown>
    			<iHotKeyPriority>0</iHotKeyPriority>
    			<FreePromotions>
    				<FreePromotion>
    					<PromotionType>PROMOTION_URBAN_TACTICS1</PromotionType>
    					<bFreePromotion>1</bFreePromotion>
    				</FreePromotion>
    				<FreePromotion>
    					<PromotionType>PROMOTION_URBAN_TACTICS2</PromotionType>
    					<bFreePromotion>1</bFreePromotion>
    				</FreePromotion>
    				<FreePromotion>
    					<PromotionType>PROMOTION_MARCH</PromotionType>
    					<bFreePromotion>1</bFreePromotion>
    				</FreePromotion>
    			</FreePromotions>
    			<LeaderPromotion>NONE</LeaderPromotion>
    			<iLeaderExperience>0</iLeaderExperience>
    		</UnitInfo>
    
    I have tested this approach, and between it and the previous your game plays to end turn ok. I have pushed a small change to SVN to insulate the DLL from the previously mentioned ROM Python bug, pending a Python fix, and built and pushed the DLL also this time since I'm in a better mood today ;-) Net is, that if you manually make the change bolded above (as a temporary measure until someone is able to fix the underlying assets problem) and take the latest DLL from SVN you should be ok.

    BTW, I'll keep this save game around for next time I do performance optimization work - it's a good test case for scalability ;-)
     
  15. Stormwind

    Stormwind King

    Joined:
    Dec 7, 2008
    Messages:
    697
    Good work :goodjob:

    I will see how far I can push the savegame, but having a 5MB save running in itself is amazing and turn times under 30 secs is even more amazing.
     
  16. BobTheBull

    BobTheBull Warlord

    Joined:
    Dec 29, 2007
    Messages:
    189
    Location:
    New Orleans
    I am having a weird problem. I had some hardware problems, a shorted hdd took out my PS. After replacing the PS not everything worked right away, but I seem to have fixed things. Except for one thing.

    I have a problem with terrain display. Features, improvements, etc. all display OK, but basic terrains, grassland, plains, water, etc. either aren't displayed at all or are too dark to see at all in game display and city screen. When I go to Worldbuilder they do show up normally. Everything else in the game appears to display normally as well.

    I did copy all the art/terrain folders from my saved clean install of AND but no change.

    Anybody got a clue?
     
  17. quamtum

    quamtum Chieftain

    Joined:
    Jul 23, 2011
    Messages:
    2
    i also use steam ver civ4 and have the same problem when i install AND 1.76 beta5
    but if I install AND in short path like c:\game\mods
    setup is sucuess, no error
    then I copy "Rise of Mankind - A New Dawn\Assets\Modules\Custom Leaderheads\Cleopatra" to steam's game path
    AND mod can work perfectly
    Maybe installer has problem when file path is too long
     
  18. zitro

    zitro Chieftain

    Joined:
    Jun 25, 2011
    Messages:
    11
    Hi, I'm not sure if this got fixed after 1.75 but almost every wonder from A New Dawn brings music that is much louder in volume than everything else, but also seems to be recorded from a $5 microphone. It's quite painful to listen to honestly.

    I'm also very concerned on forcing the fixed borders idea after 1.75 and how it could remove incentives for increasing culture. Will there be an increase in the likelihood of revolts in cities overwhelmed by nearby culture? What will happen to opponent's culture once you capture a big city? Would you be able to make to overtake that culture without having units claim land?

    There were a few minor concerns mostly involving balance (e.g. the casino is quite counterproductive), but they might have been taken care of already with 1.76 and given the massive scope, it's not only well balanced in 1.75 but the AI is quite good.

    The mod is fantastic! It can get a bit overwhelming with the number of buildings, but Keep up the good work.
     
  19. Koshling

    Koshling Vorlon

    Joined:
    Apr 11, 2011
    Messages:
    9,254
    See this thread: http://forums.civfanatics.com/showthread.php?t=428575 - no idea when I'll get round to the proposed changes though, as I am bogged down in AI work currently.
     
  20. RageaiR

    RageaiR Chieftain

    Joined:
    Jul 25, 2011
    Messages:
    1
    Hello hello! :)
    First time posting here, and I'm not sure if something I'm giving feedback on have already been discussed here, If so, I apologize!

    I love playing this mod, seeing civilizations rise and fall and enjoying the dynamics of the game. I don't play at a very high difficulty setting, I usually use flexible difficulty prince-emperor for the most part. I do not know if my difficulty setting are related to the feedback I'm giving, but I don't think it is.

    Some general feedback and things that I find to be weird:

    Civics. The AI absolutely loves monarchy, patrician, coinage/guilds and later on federal and volunteer army to such a degree that they don't choose anything else, even if the leader for example have a favorite civic of despotism. I have no idea why this is. Ive played numerous games from ancient - modern and the trend is clear. They all rush for monarchy and then they all use monarchy until they get to rifling when they all switch to federal. This is quite boring and it feels like the AI is power-gaming. The categories where the AI players differ the most is religion and welfare, they use almost all the available civics which feels fun. The AI never use civics which disables foreign trade routes.

    Unhealthiness. At the beginning of the industrial era you get access to a load of buildings who give a rather significant unhealthiness penalty. The AI don't seem to mind the unhealthiness though and usually shrinks his cities down to maybe 5-1 pop, which In my opinion is not very fun as they usually come out crippled afterwards. Maybe the AI should try to build a healthiness building for every factory/coal plant/etc it builds? As Ive seen from espionage they usually don't build healthiness buildings often at all.

    Religion. Religion is my favorite part of the game and I often play with Limited Religions to spread them out a bit more. I do feel that a few religions need a buff though, mainly Christianity and Islam. I think, If possible, that the number of free missionaries the founder gets should be based on map size to balance things out a bit. I have seen Christianity actually succeed once in my entire AND career but i have still to see Islam even spread beyond a few % before the time religions start to lose their power in the modern era. A alternative would be to let Christianity and Islam spawn a great prophet, as civs that acquire a religion late are a bit less likely to spawn one themselves?

    Religion decay. Its mainly a personal preference, but I would like it if religions did not decay from a city with the religions buildings in it even if its not the state religion, like a monastery or a shrine. Perhaps the religions could start decaying after 1000 years (when the buildings reach double culture) to symbolize religions lost to time?
    If religion decay is turned on, the civic secular is a bit to weak as a city will only have max 2-3 religions, if this was implemented secular leaders could construct temples to the religions to keep them in his cities.

    Civilizations. I find it weird that both the Native Americans and the Iroquois are playable, are the Iroquois not Native Americans? Perhaps the Native Americans should be renamed the Sioux or something if possible?

    War. Now, this one I'm unsure if its possible to fix, but I find it annoying. Civs like to declare wars on Civs on different continents even if they are nowhere near to have the technology for boats or ocean sailing. They also like to declare wars and then do absolutely nothing about it if they are on another continent.
     
Thread Status:
Not open for further replies.

Share This Page